We help IT Professionals succeed at work.

SBS2003 REMOTE WORKPLACE DOES NOT WORK

jeoinc
jeoinc asked
on
594 Views
Last Modified: 2008-04-24
SBS2003 REMOTE WORKPLACE WAS WORKING GREAT AND THEN STOPPED - I HAVE RUN THROUGH THE WIZARD TO RECONFIGURE BUT IT DOESN'T HELP.  WE CAN USE /EXCHANGE BUT THE /REMOTE DOES NOT WORK - WE RECEIVE THE FOLLOWING ERROR MESSAGE:
Server Error in '/Remote' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
I HAVE APPLIED SBS2003 SP2 BUT IT DID NOT HELP EITHER.
Comment
Watch Question

There is no SP2 for SBS, there is one for Exchange 2003 or Windows. Or are you talking about R2?
What versions of .Net do you have installed on the server?
Thanks,
David

Author

Commented:
YES IT IS R2
I SEE MICROSOFT .NET FRAMEWORK 1.1 --DEVICE UPDATE 4.0
BUT I DON'T SEE ONE THAT SAYS .NET FRAME WORK 1.1 ?? DO YOU THINK THAT IS THE PROBLEM?
The default website does need to be set to .Net 1.1 in IIS.
To check this, open the IIS snap-in, goto websites, right click the Default Website, and goto Asp.Net
It should tell you asp.net version.
Thanks,
David

Author

Commented:
THERE IS NO ASP.NET UNDER DEFAULT WEBSITE
THERE IS A FOLDER CALLED "ASPNET_CLIENT"
Could you please turn off your CAPS Lock.
If you go into Windows Explorer, and navigate to the windows directory, then to the Microsift.Net folder, then the frame work folder, there should be three folders which start with V, could you please list all the folders that start with V.
Thank you,
David

Author

Commented:
there are only two
v.1.0.3705
v.1.1.4322
Okay, we may need to reset .Net 1.1 but for the moment lets see one other thing.
When a failed connection is made to RWW there should be an event in the Event viewer that will have more information about this.
If you could post any errors from the system and application logs to here,I should have a better understanding.
Thank you,
David

Author

Commented:
there is nothing in the event viewer - i checked application and system
One quick question, did you install the Service Pack 2 for Windows 2003?
Thank you,
David

Author

Commented:
yes, but after it was not working - i thought it might help
What ports do you have forwarded to the server?
443 and 4125 should be.
The Win2K3 sp2 requires that netork card drivers be updated to the latest release and that certain network features be disabled on the card or the hotfix that was released in the last few days. Have you gotten that hotfix?
Thank you,
David

Author

Commented:
all of the latest security updates are done - what is the kb on the hotfix?
i can't reboot the server right now because of open files

yes, 443 and 4125 are forwarded - it has been working fine for over a year and all of a sudden, it just quit working and gives the message that i first posted.  It prompts you to accept the security certificate and then it gives the message
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
If you've installed Win2K3 SP2, then that's probably what caused the problem.  

http://blogs.technet.com/sbs/archive/2007/06/01/unable-to-rdp-rww-into-the-sbs-server-after-applying-sp2.aspx

You may want to review any other issues with SP2 on SBS as well:

http://msmvps.com/blogs/bradley/archive/2007/06/01/before-you-install.aspx

Jeff
TechSoEasy

Author

Commented:
the problem is not with RDP it's with RWW - and it was happening before I applied the SP2
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
Okay... how about following the instructions that are in the error message above so we can view the actual error that's occuring.

You can either modify the Web.config file in C:\Inetpub\Remote as instructed, or you can just disable Friendly Error Messages in the browser you are using that generated the above error.  (In IE's Properties > Advanced Tab > Browsing > uncheck "Show Friendly HTTP Error Messages").

Then, recreate the error and see what the full error message really says.

Jeff
TechSoEasy

Author

Commented:
i turned of the "show friendly http erro message" and i received the request to accept the security certificate like normal, but then the browser gives the same message:
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>

i don't know if i mentioned before that we can perform the https://ipaddress/webaccess and that works fine... so it is just the /remote. but again, rdp works fine....

i am not sure about editing the Web.config file in C:\Inetpub\Remote as instructed

any other thoughts?
Jeffrey Kane - TechSoEasyPrincipal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014

Commented:
First, for https://ipaddress/webaccess... what's that?  Do you mean /exchange?

Then, "i am not sure about editing the Web.config file in C:\Inetpub\Remote as instructed"... what are you unsure of???  Make a backup copy of the file first, then hack away at it and get us the information we need.

Jeff
TechSoEasy

Author

Commented:
its been a long day out in the field - actually a long couple of weeks with problems.... yes, i meant "/exchange"  so it is just /remote not working.

i haven't really read the instructions about the web.config file yet, i will do that next and see what it says to do.
Principal Consultant
CERTIFIED EXPERT
Most Valuable Expert 2016
Top Expert 2014
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
ok i backed it up but i don't see the instructions on which things i need to change.  i hope i am not being silly and missing it but i reviewed back and don't see it - can you cut the instructions in again for me or a link again.  I have checked out the other two links above and do not see what i need to do.  thanks so much for your help.

Author

Commented:
never mind - i see the instructions have been in front of me the whole time - i copied and pasted them from the website, duh!  ok,  i will try it now.

Author

Commented:
ok, i finally figured it out - after i put those codes in based upon the article, it showed me that it could not write to a directory - i googled it and the following article is what solved the issue:
http://support.microsoft.com/kb/825791

thanks for your support!

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.