We help IT Professionals succeed at work.

Cisco Pix - Active Directory Authentication & allow network browsing

fusioninternet
on
1,822 Views
Last Modified: 2011-09-20
Hi  All

I have managed to setup a cisco pix 501 to allow incoming vpn connections and have a couple of additional things i would like to be able to do.

I am fairly sure this is possible but haven't a clue on how to do it!

1. Can all remote vpn users use Active Directory for authenication of username and password (instead of creating users in the pix)

2. Is it also possible for vpn users to browse the network though network neighbourhood so they can connect up to shares/printers etc

Any other advice you could pass on to allow the remote users experience to be improved would be greatly appreciated.

Regards

Justin

My config file

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password <removed> encrypted
passwd <removed> encrypted
hostname 501-01
domain-name domain.local
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group service inboundallowedTCP tcp
  port-object eq www
  port-object range 3389 3389
  port-object eq domain
  port-object eq https
  port-object eq smtp
access-list 101 permit tcp any host <removed> object-group inboundallowedTCP
access-list 101 permit tcp any host <removed> eq www
access-list 101 permit tcp any host <removed> eq https
access-list 101 permit icmp any any echo-reply
access-list 101 permit tcp any host <removed> eq smtp
access-list inbound permit tcp any interface outside eq https
access-list inbound permit tcp any interface outside eq smtp
access-list inbound permit tcp any interface outside eq www
access-list inbound permit tcp any interface outside eq domain
access-list inbound permit tcp any interface outside eq 3389
access-list inbound permit tcp any interface outside eq 3390
access-list inside_outbound_nat0_acl permit ip 192.168.111.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list RemoteVPN_splitTunnelAcl permit ip 192.168.111.0 255.255.255.0 any
access-list outside_cryptomap_dyn_40 permit ip any 10.0.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside <removed> 255.255.255.0
ip address inside 192.168.111.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool RemotePool 10.0.0.100-10.0.0.200
pdm location 192.168.111.2 255.255.255.255 inside
pdm location 192.168.111.3 255.255.255.255 inside
pdm location 194.168.83.233 255.255.255.255 outside
pdm location 194.164.83.233 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp <removed> smtp 192.168.111.2 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.111.2 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.111.2 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface domain 192.168.111.2 domain netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.111.3 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3390 192.168.111.2 3390 netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 <removed> 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.111.0 255.255.255.0 inside
http 192.168.111.2 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash sha
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup RemoteVPN address-pool RemotePool
vpngroup RemoteVPN dns-server 192.168.111.2
vpngroup RemoteVPN wins-server 192.168.111.2
vpngroup RemoteVPN default-domain omni.local
vpngroup RemoteVPN split-tunnel RemoteVPN_splitTunnelAcl
vpngroup RemoteVPN idle-time 1800
vpngroup RemoteVPN password ********
telnet timeout 5
ssh <removed> 255.255.255.255 outside
ssh 192.168.111.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd address 192.168.111.2-192.168.111.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username fusion password <removed> encrypted privilege 15
username steve password <removed> encrypted privilege 15
terminal width 80
: end
[OK]

Comment
Watch Question

Technical Architect
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Pete LongTechnical Architect
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
>>2. Is it also possible for vpn users to browse the network though network neighbourhood so they can connect up to shares/printers etc

Usually not - this depends on NetBIOS - Im not sure if this will work when connected.
Pete LongTechnical Architect
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
I Know you are on a 501 and using v6 but heres a walkthrough I did for authenticationg VPN client to windows from an asa running v7 - the procedure is more or less the same (ignore the CLI section at the end though thats very different)
http://www.petenetlive.com/Tech/Firewalls/Cisco/c2svpnRADIUS.htm


Les MooreSystems Architect
CERTIFIED EXPERT
Top Expert 2008
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Hi,
Thanks for you previous posts they have help greatly.

The instructions provided by Pete have got me  quite way, but the instructions start to break away from the version that I'm running at about midway throught the section " Add the RADIUS server to the ASA5500 ". Where you can test the connection. Also just after that it goes onto mention about pre shared keys etc.
The sofware I'm running is Pix Device Manage 3.01 and the client (which doesn't give me any options as shown in the walkthrough) is 4.6.00.0039.

Again, any help to achieve the final goal of being able to VPN in and logon using their AD usernames, is most appreciated.

Regards
Justin
Pete LongTechnical Architect
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Old Link above see http://petenetlive.com/KB/Article/0000071.htm instead
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.