We help IT Professionals succeed at work.

Deploying a web service - Authentication mode error

925 Views
Last Modified: 2013-11-26
I'm trying to deploy a web service that works find on my development machine but when on the web server comes up with the following error message.  

Server Error in '/' Application.
--------------------------------------------------------------------------------
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:
Line 49:             ASP.NET to identify an incoming user.
Line 50:         -->
Line 51:             <authentication mode="None"/>
Line 52:             <!--
Line 53:             The <customErrors> section enables configuration
Source File: E:\WWW\Ibis\webservice\web.config    Line: 51
-------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42
Comment
Watch Question

This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Your right, when its a virtual directory is works.  I never realised a virtual directory was more that a simple mapping function.  Is there a reason for this behaviour (ie am I missing some IIS concept)

Also, when requesting accross the internet I get the message "...is only available for requests from the local machine", again, is there some simple setting I am missing ?

Thanks for your help
when you go to the web service test page from another machine you mean?
as long as the parameters are simple types, you can add this to the web.config, inside system.web, and it should enable you to test from another machine.
   <webServices>
        <protocols>
          <add name="HttpPost"/>
        </protocols>
    </webServices>

Author

Commented:
Thanks for your help steveberzins, both parts worked.

Still curious about why it need to be a virtual directory - one ony the namy mysteries of IIS for me.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.