We help IT Professionals succeed at work.

Coldfusion Jrun and ODBC problems

4,078 Views
Last Modified: 2013-12-20
We just reinstalled ColdFusion MX7 on a Windows 2000 server. This machine used to have an old version ColdFusion MX 6 on it, but that has been uninstalled. There seem to be remenants from the uninstallation left on the machine, but the MX version does not appear in the add/remove programs list, or in the services list anymore.


When attempting to use ODBC datasources, the following error is encountered:

java.sql.SQLException: [Macromedia][SequeLink JDBC Driver][SequeLink Server]The specified data source is not defined.
The root cause was that: java.sql.SQLException: [Macromedia][SequeLink JDBC Driver][SequeLink Server]The specified data source is not defined

If I go to edit or verify a ODBC source in the administrator, the following error is returned:

The ColdFusion MX 7 ODBC Server service is not running or has not been installed.


I have tried using the SequeLink Setup CFServiceController.exe program to reinstall the ODBC services, but every time it installs "ColdFusion MX ODBC Agent" and "ColdFusion MX ODBC Server" it should be installing MX 7, not MX.

When it installs the wrong version, the services will not start, instead they say the specified file cannot be found.


In addition, we have been having intermittent crashes of JRun, requiring the service to be restarted.  When it fails, HTTP 500 errors are sent to the visitors such as this:

Server Error
The server encountered an internal error and was unable to complete your request.
Could not connect to JRun Server.

Generally, the service is not responsive (it must be force-ended in task manager, services.msc is unable to communicate with it.)

Any ideas
Comment
Watch Question

Commented:
Yes, a simple way to solve this in Windows is to format the machine, install Linux and do your work properly.

Author

Commented:
>Yes, a simple way to solve this in Windows is to format the machine, install Linux and do your work >properly.

Ha, if it were up to me, I'd be totally with you on that one.  I'm not a fan of Windows web servers, or coldfusion for that matter.

However, this is a production box running a lot of stuff designed for a Windows + ColdFusion environment (plus, I don't own it, just assigned to do tech support on it) so changing the platform is not an option.

As far as reformatting, if nothing else can be done, my plan is to recommend a full reformat and reinstall of everything.  However, this is a PRODUCTION web server that is currently online, and has no cluster or failover backup so when this thing goes down, there's nothing to pick up the slack.

A reformat will leave it out of commission much longer than I'd like to risk.  Also, there's a ton of stuff installed on it that would be difficult to recreate.  (This guy has this machine running ColdFusion MX7, IMail POP3 / SMTP server, Microsoft SQL 2000, MySQL (installed but not currently running))  That said, I've been monitoring free memory and cpu utilization, the box has shown no signs of overloading.
CERTIFIED EXPERT
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT

Commented:
"Yes, a simple way to solve this in Windows is to format the machine, install Linux and do your work properly."

that's a comment more appropriate for the lounge... and is certainly no help

Author

Commented:
The datasource is an excel file, so ODBC is required.

Does anyone know of a way to manually install the MX7 ODBC services? I'd just assume try that first before killing the whole CF install.

If not, I'll be doing a clean CF install tomorrow morning, will let you know how it goes...
CERTIFIED EXPERT

Commented:

Author

Commented:
I actually tried that article yesterday,  I followed the instructions it provides for MX 7, but it installs the MX version of the service every time anyway.

If you open up the batch file it referrs to, there are entries for both MX and MX 7, I removed the MX from the batch but the executable still installs MX.  I think there is something crossed in the registry
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
http://www.bpurcell.org/blog/index.cfm?mode=entry&entry=1018
Found a suggestion in this entry. Don't know if it works but you might try it as a last resort

- Uninstall the odbc services
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19135&sliceId=1
- Re-run the config wizard  
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19373&sliceId=1


Author

Commented:
Well we bit the bullet and took SidFishes suggestion and did a clean install of ColdFusion.  Obviously took the server out of commission for a while but looks like it's working now :)

I used that RegCleaner, it got some orphaned entries but interestingly still missed all of the old ColdFusion 5, MX and MX7 entries that were still in there. I was able to remove most of these by hand in regedit.

Thanks everyone!
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.