We help IT Professionals succeed at work.

Active Directory Corruption - many languages displayed

8,721 Views
Last Modified: 2008-06-01
I am attempting to set up a Kiosk machine along with a user account which has no permissions or rights on the domain.  The computer in question was not picking up the new policies I set so I fired up the Resultant Set of Policy tool and entered the name of the computer and the user to generate a result set.  In the Computer Configuration > Admin Templates group I got many languages displayed.  This problem is hard to describe so I have posted a screenshot here.

http://www.mhsaa2.net/tech/problem.jpg



Comment
Watch Question

Commented:
This is ODD!  

First thing that comes to mind is some virus, but I don't really think that is it.  I would however check this.

I don't think it is corruption as AD will not replicate with Corrupt and Divergent Partners unless you have it set up in the registry to do so.  

Check your AD replication with replmon.  Look at all partners and get back with us on the results.  Then we can take if further.

Author

Commented:
I've never used replmon before.  Ill read up on it and get back with you tomorrow.

We have Symantec Corporate edition installed on our network.  It updates every day, all systems have real time protection enabled, and scans are done nightly.  I checked the logs and there is no mention of a virus.  

The strange languages are displayed on every machine I run the RSoP tool from although the number of lines of non-english text varies as well as the number of contianers dispalyed.  I would think that at least the same number of containers would come up regardless of where I view the Admin templates even if they are in different languages.  

This problem only occurs in the RSoP tool, not in the GPO Policy editor.

Commented:
Run replmon from the Start - Run.  Then add the DC / DC's and expand the AD partitions and look for issues.  Pretty self explanatory

http://technet2.microsoft.com/windowsserver/en/library/691910f2-a6a7-4ced-984e-972aec2cbdd21033.mspx?mfr=true.

Author

Commented:
You were right, very self explanatory.
There does not appear to be any replication issues with AD.  All of the containers had logs that indicated that replication was successfull.
I ran a check for replication errors and no problems were logged.

Author

Commented:
Another thing I noticed today.  When I run the RSoP tool from an XP workstation it displays correctly.  When I run RSoP from one of the Windows 2003 servers ( DC or Member Server) the non-english items display.

Commented:
I think it is just a problem with RSoP.  Perhaps a patch or SP caused the issue.  If AD is replicating I wouldn't worry about it, but if you really need the RSoP results then you will have to troubleshoot this out.

I would check my "languages" settings and maybe even change the English current version, to some other english version and then back again to see if that might fix it.

Does anything else look screwy?

I am really stretching here...   Is there any chance that you are pulling RSoP's from any client machines that may be set up in other languages.  Also, was there ever a time when your server was set up in a different language?


Commented:
Also,

Try this and see what the results are.

Command prompt

gpresult /v > gp.txt

Author

Commented:
The gpresult txt file looks ok.  We are a small shop of about 30 computers with no other offices.  The servers have never been set up with another language.
On one of the servers when I run the RSoP tool I am now getting the following errors when I attempt to expand the Computer Config > Admin Templates container.

The following error occured in C:\Windows\Inf\AER_1044.ADM on line 30:
Error 64  Help string specified more than ince
File cannot be loaded

The following error occured in C:\Windows\Inf\AER_1028.ADM on line 30:
Error 64  Help string specified more than ince
File cannot be loaded

The following error occured in C:\Windows\Inf\AER_1044.ADM on line 189:
Error 64  Help string specified more than ince
File cannot be loaded

The following error occured in C:\Windows\Inf\AER_1028.ADM on line 189:
Error 64  Help string specified more than ince
File cannot be loaded

Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
Any progress?

Author

Commented:
Sorry for not updating you sooner.
I finally had to break down and call Microsoft.  After a 3 hour phone call they ended up moving several .ADM files form the C:\Windows\Inf folder.  The only moved them to the dekstop to get them out of the inf folder.  I guess they though I should keep them around just in case.   This is a known issue but it is not documented on the MS KB website.  MS does have several internal SRX cases though.  The one they used to figure out my problme was SRX070123602896.  Hopefully that will he helpfull to someone who has to call them.  It took them quite a while to figure out exactly what was going on.

This is a list of the files they removed from the inf folder
AER_1025.ADM
AER_1028.ADM
AER_1031.ADM
AER_1033.ADM
AER_1036.ADM
AER_1040.ADM
AER_1041.ADM
AER_1042.ADM
AER_2052.ADM
AER_3082.ADM

When I have time I am going to add these files back in the /Inf folder one by one to determine which ones were causing the problem.
I appreciate your help though your suggestion about the templates being corrupted was correct.  It just ended up being more templates than Windows was reporting.



Had the same issue. I had the luxury of having another SBS server (ServerB) at another location.
I cut all of the AER_XXXX.ADM files from the corrupted server (ServerA) and placed them into a temp folder.
Copied the AER_XXXX.ADM from ServerB to ServerA.

Conclusion: No more errors.
ServerA had 39 AER_XXXX.ADM files
ServerB has 10 AER_XXXX.ADM files
(1025, 1028, 1031, 1033, 1036, 1040, 1041, 1042, 2052, 3082)


UPDATE: I moved the original files back, but only these ones: (1025, 1028, 1031, 1033, 1036, 1040, 1041, 1042, 2052, 3082).
All seems to be working well.

Just found this post, as well.. stating not to delete the 1033:
https://www.experts-exchange.com/Software/Server_Software/File_Servers/Active_Directory/Q_23762177.html?sfQueryTermInfo=1+10+30+64+aer_1044.adm+c+error+follow+help+inf+line+more+occur+onc+specifi+string+than+window#a23031873

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.