We help IT Professionals succeed at work.

MS Access 2003 'you do not have necessary permissions to use'

4,576 Views
Last Modified: 2008-07-16
I have 10 PC's with Win XP Pro running on a WIN server 2003 network.  The PC's are all 1 ghz machines. 2 of the PC's were replaced with new ones. The new PC's were joined to the domain and all seeming ly worked ok, until MS Access was used.  I receved

"you do not have necessary permissions to use <path to mdb> object. Have the system adminstrator or the person who created this object establish the appropriate permissions for you."

The databases are on a netwrokdrive and shortcuts are on the desktops.

Within Access, the databases were joined to a .mdw file that the others seems to be using. No one can can access various databses now without rejoining a different .mdw. I am not sure the mdw files needed re-joined since this is a PC install and the databse is on a netwrok drive with its .mdw.

Any help would be appreciated.  I will answer any additional questions.
Comment
Watch Question

Commented:
Hello www_JamesClancy_com,

Well let me see if I understand your situation. You have 10 PCs that are trying to access a MDB file on a network shared drive. The MDB is locked down by user access. the 8 original PCs are still able to access the file with no problems, but the 2 new ones are not able to get to it?

The 2 new computers were freshly installed with access 2003 and I am guessing here you created a shortcut to the MDB file on the desktops of those 2 computers.

Well here is what I see.

To access a MDB file that has security on it by user name you need to open the MDB file through the MDW. Basically the MDW holds all the information for the users in it, so if it is not used to open the MDB the MDB will not open.

Now to use the MDW file it is slightly complex because there is a series of strings within it. But you don't really have to worry about that since you do have 8 other computers that are still working. Basically copy the shortcut from one of the other computers and past it to the new computers then try accessing your MDB files again.

The other way of doing it is looking at the properties of your other shortcuts and then checking all the information in the target box. I think the method used in it was "path to access's exe" "path to the MDW" "path to MDB" but I would need to look at a shortcut for database with security to make sure again. So please let me know how things are going,

Bernard

Author

Commented:
Thank you..this is sounding close to what I need. In addition...

I know that if I "JOIN" the default system.mdw, I can use 1 particular database that was a covert from Access97....but the other 2003 databases get permission errors(I believe there are tables linked). The various databases all share each other's data.

When I "JOIN" back to the mdw called "Security.mdw"...the 2003 databases can be used..but the older databse that was coverted to 2003 gets the permission error.

I did copy a DAO the was required to the "Microsoft Shared" folder on the users' C: drive.

How is the path suppose to look in the short cut?

Like this with slashes and spaces?  
<path to access.exe>  \<path to the MDW>  \<path to MDB>

Commented:
Here is the target of a shortcut for a secured mdb that I have. I have removed a lot of the path information but you can see how it is laid out in any case.

"C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE" "X:\path\name.mdb" /WRKGRP "X:\path2\Security.mdw"

I normally just open the MDBs through a shortcut instead of adding the security.mdw to access. It allows you to use many different mdw files.


hope this helps,

Bernard
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database Architect / Application Developer
CERTIFIED EXPERT
Top Expert 2007

Commented:


Here are some links ... check out the first link especially.

step by step instructions on how to do it RIGHT:
www.jmwild.com   

Excellent resource book which I have
http://www.vb123.com/map/       

Microsoft info:
http://support.microsoft.com/default.aspx?scid=%2Fsupport%2Faccess%2Fcontent%2Fsecfaq.asp
http://support.microsoft.com/?id=207793

mx
--------------------------------------

Author

Commented:
Update---I tried the new shortcut with the paths defined and received the same results. I pulled an old version of this databse off a backup prior to the install of the new PC's.  There is a difference in the user and group settings. On the present database, near the bottom of that window...it shows a box with the 'current user' as "Admin.

On the backed up copy of the database before the installs of new PC's.... the current user is a logon name.

How can I change the "current user"? that box is not editable.  

Commented:
does access ask you to login as a user using the updated or copied shortcut?

I guess not since it does not sound like you are logged into the database. That is weird and annoying.


Did you copy your MDW file over the default system MDW? or are you using the shortcut to go to a different one?

I am grasping at straws a little bit here because I am not sure why it is not working. I know that you need the shortcut and it needs to open the MDW file before opening the MDB. I normally keep the MDW file in the same folder as the MDB and just link through it. Also once a MDW file used to opened a file then that access session uses the permissions granted through the MDW. You have to close and then open Access to use a new MDW file (login).

I hope we can figure this out.

Bernard
Database Architect / Application Developer
CERTIFIED EXPERT
Top Expert 2007
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Hello and thank for you help. I am understanding more than I ever wanted to about Access security..LOL.

I There are 2 users in the Access databse. Admin and an actual windows logon name.
Both are in teh Admins group.

When I go to other databses using Security.mdw..I can see that the Ownership of the database is that logon name.

When I go tot he database having trouble....the Ownership is "<Unknown Ownership>"

The Change Owner button is greyed out and I am logged in as the logon name that is suppose to be that Admin.  I think this is where my proble is.  I belive this database has got be owned by that same logon name just like the others.....since they all have linked tables and queries.  

Ever hear of the Ownership being greyed out when logged in as the apparent Admin?

Commented:
HERE IS THE REAL SOLUTION:

Internet Explorer Enhanced Security component is causing the problem.
This security update also stopped some of our links between Excel and Access - be warned.
Solution:

In IE, open Tools and Settings, press Security and then Local Intranet, and Sites. Add the location of your database (ie. file://serverblaa). Now you can open the MDB without errors ... Of cause you need the proper access rights to the locations of the DB.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.