We help IT Professionals succeed at work.

NSLOOKUP error on SBS 2003

1,371 Views
Last Modified: 2008-04-24
NSLOOKUP error on SBS 2003

I have a SBS 2003 Premium Edition and I'm getting and error message when access NSLOOKUP from he DNS console. The message contains the following, "Can't find server name for address 10.121.50.10: Non-existent domain  
Default Server : Unknown  
Address : 10.121.50.10
>nslookup myservername
Server: myservername.mydomain.local
Address: 10.121.50.10

*** myservename can't find nslookup: Non-existent domain

I tried running the Internet Connection wizard to fix this problem but still the same result.

Any help would be much appreciated
Comment
Watch Question

can you check if your sevrver has registered it self with the dns , and whether it is poinintng to itself for the dns. if not stop and restart the netlogon for the SOA records to be registed with the DNS.

Hope this helps
Cheers:)
Kamal

Commented:
>>"Can't find server name for address 10.121.50.10:

because your reverse zone is not configure. In dns management go to reverse lookup zone then create new zone for range 10.121.50, after that add pointer for 10.121.50.10.
after that do nslookup and it will not give you above error.
CERTIFIED EXPERT
Top Expert 2006
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Commented:
>> should resolve the name with or without a RLZ unless you are trying to resolve via IP its irrelevant

i think you have to check its error,

>>>>"Can't find server name for address 10.121.50.10:

thats mean the reverse entry for server is not define.
Here is what I have in the Reverse Lookup Zones

Reverse lookup zones I have 192.168.0.x subnet  10.1.1.x subnet and 10.121.x.x subnet all are active directory-integrated primary and running
I'm not sure if any of these are needed or correct

I have two NIC's one for the internal network using IP 10.121.50.10 and subnet 255.255.0.0 and an external NIC at address 192.168.2.2 and subnet 255.255.255.0

Added reverse lookup zone 10.121.50 and had same error.
Ran ipconfig /registerdns and its working fine
CERTIFIED EXPERT
Top Expert 2006

Commented:
>>>>thats mean the reverse entry for server is not define.

all that means is that the server it is looking for the record on doesnt have it registered correctly. RLZ only come into play for reverse lookups on an IP
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.