Lotus Notes Scheduled Agent - Error in Loading DLL

daviesgroup
daviesgroup used Ask the Experts™
on
We use an address lookup system (QAS) within our bespoke Domino application.  The address data, dll's and ini files are on a network path, and the code in the application looks at this when searching for addresses.  This works really well.

I have a requirement to automatically create some Notes documents, which will involve populating an address.  I have written a scheduled agent that picks up data from a SQL table and creates a Word document, which is then attached to a Notes document and saved in our application.

If I test this agent from my client, it works fine, but when running from the server I get the following error:

"error: Error in loading DLL"

This occurs at the point where the agent is carrying out the address search.  The server is able to access the network path and see the ini/dll files.  I have tried moving the ini file/DLL locally onto the server in various locations, including windows\system32 and the domino application directory, but always get the same error.

Any help would be greatly appreciated. Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
From my experience, .... (ofcourse not related to DLL stuff)
The DLL is not authorized to run against the Address book. Since access is needed.
In the DLL, you can pass the username and password to access  the Address Book.
Hope it helps.

-Maddy
For confirming access problem, when the DLL access the Address Book, check the log file in Domino server. It should give 'You are not authorized...." some sort of access denial message.
To over come this, you need to pass User Name and password as we do to send email through VB.

Author

Commented:
There are no authorisation problems on the server. The only message thats comes up on the server log is the Error in Loading DLL.  I have put print statements around this area of my code to confirm this, so I can see what's happening.

Why would the DLL access the address book?  QAS is an off the sheld address lookup tool. You pass a post code and house number/name and it returns the full postal address. The DLL is part of the QAS software.
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

Oh...I see.
I am not aware of QAS software.
Apolozise for providing a wrong suggestion.

Author

Commented:
No problem madheeswar, thanks for trying...

Author

Commented:
Thanks for that.  I had tried everything mentioned here, but still no joy.

Commented:
First thing I would do is try running the client on the server and confirm that QAS works on the box altogether.

Next thing I would do is confirm that your agent is authorized to make calls to DLLs.  I doubt that is the problem, because I would expect a different error, but you never know.

Next, I would contact the vendor and find out if there is anything they need to set up WITHIN the application.  There might be issues with teh DLL you are claling needing to call additional DLLs and not being able to find them.

It might also be worth finding out if they have another way to call the system, such as OLE, COM, ActiveX, DDE, or running an EXE with parameters.
PAQed with no points refunded (of 500)

Computer101
EE Admin

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial