No remove buttons or unistall options in Add / Remove Programs

When I go to Add / Remove programs, the program exists, but the "Remove" or the "Change / Remoe" button doesn't exist.  

I have read this post, but no help
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_22080751.html?sfQueryTermInfo=1+add+button+program+remov

this entry in my registry does exist. what should i do?
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
NHChatsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeTutorretiredCommented:
You need to find the key for the program you want to remove under the Uninstall subkey.  Then look for the subkey under that for "UninstallString".  Double click it, copy the contents to the Run dialog box off the Start Menu, and hit the Enter key.  What program is it you're trying to remove?
NHChatsAuthor Commented:
LeeTutor,

this key does NOT EXIST in the registry.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

all of my "add/remove" button are gone from all the programs listed.
LeeTutorretiredCommented:
So you made a typo in your question?  Because in that you said:

>this entry in my registry does exist


If that is true, try this page:

http://www.winxptutor.com/arpbuttons.htm
Some applications in Add/Remove Programs list are missing Change and Remove buttons
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

NHChatsAuthor Commented:
LeeTutor,

I installed  a program and now the key: "now shows up!"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

but the only entry is the program i just installed.  

what happen to the rest of the list?
how do i restore the list?





NHChatsAuthor Commented:
LeeTutor,

yes i made a typeO!!!!

I MEANT TO SAY...
>this entry in my registry does NOT exist.
LeeTutorretiredCommented:
Sounds like your registry has become corrupted.  The only way of getting back to a version that has that key existing is to use System Restore to revert to a date before your problem appeared.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NHChatsAuthor Commented:
LeeTutor,

I did exacly what you said to do and used system restore and that worked.

thanks

NHChats
LeeTutorretiredCommented:
Very good, glad it worked!
DCProfessionalCommented:
Can anyone suggest where I begin troubleshooting, a case where a systems' entire Change/Remove functionality is lost for ALL the applications installed?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.