Solved

Sharepoint pages are slow to load the first time they load.

Posted on 2007-07-09
7
3,788 Views
Last Modified: 2010-11-02
Any way to speed up the loading of sharepoint 2007 pages the first time they load?
0
Comment
Question by:binnykuriakose
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 16

Expert Comment

by:cobrachen
ID: 19448733
If you restart IIS or reboot the server, it will load slow.

If the site you feel pretty slow has publishing feature turned on, you may want to setup file system cache to enhance the performance.

If all sites are running slow and you do not have SSL setup, add one more IIS processor to the same web application.

Otherwise, please provide more information.

Thanks.
0
 

Author Comment

by:binnykuriakose
ID: 19448797
ok.  let's break this down.  anytime, i hit the first page of the sharepoint site, it loads slow.  if i go to another page, and come back, it loads fast... since it is cached on my machine.  if i close IE, it will load slow again the first time i hit the page.  i have SSL setup.  

will file sys cache help. how is that configured?
0
 

Author Comment

by:binnykuriakose
ID: 19448833
actually, closing and reopening IE does not produce this.  Only the first time, i hit the site.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 16

Accepted Solution

by:
cobrachen earned 500 total points
ID: 19448834
Unless you turn on site publishing feature, then cache will not help.

Since you have SSL, it's possible due to the authentication like we have. If you have another URL to access the same site collection without SSL, try to compare the performance.

Thanks.
0
 

Author Comment

by:binnykuriakose
ID: 19448983
it is the same whether i hit the site using http or https.
0
 

Expert Comment

by:srivatsan24
ID: 21558505
you have to go through this article. the sharepoint site is slow the first time is by desing. read the following to know more
http://blogs.msdn.com/joelo/archive/2006/08/13/697044.aspx
0
 

Expert Comment

by:ShopLiftin
ID: 34041493
Go to IIS > Application Pool > Right-click DefaultAppPool > Click Properties > Click the Performance Tab > Uncheck your Idel Timeout.

This is likely your issue for first loads and the issue will only recur after server/service reboots in the future.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Scenario: Let’s say you have a quote worksheet in Excel that you use to work up sales figures and such for your clients. You utilize SharePoint to manage and keep track of these documents. You would like values from your worksheet to populate Sh…
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question