• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 517
  • Last Modified:

Implementing PIX 501 access-list does not apply changes

Hello
I am having difficulty applying an access list to a Cisco PIX501 firewall.
I added the following statements that have a * next to them to an existing access-group.

However, I still cannot access the internal computers from the outside. They work fine from the inside.

* access-list int-outside permit tcp any host 44.44.117.116 eq www
* access-list int-outside permit tcp any host 44.44.117.116 eq https
* access-list int-outside permit tcp any host 44.44.117.116 eq 3389
* access-list int-outside permit tcp any host 44.44.117.117 eq https

maybe I should have created an new access-list.
Thank you for your help.

James
I changed some IP info for security reasons.

************************
sh run
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ex3AND3rYnc8N9r encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name syssrc.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list int-outside permit tcp any host 44.44.177.125 eq ftp
access-list int-outside permit icmp any host 44.44.177.125
access-list int-outside permit tcp any host 44.44.177.125 eq www
access-list int-outside permit tcp any host 44.44.177.124 eq 3389
access-list int-outside permit icmp any any
* access-list int-outside permit tcp any host 44.44.117.116 eq www
* access-list int-outside permit tcp any host 44.44.117.116 eq https
* access-list int-outside permit tcp any host 44.44.117.116 eq 3389
* access-list int-outside permit tcp any host 44.44.117.117 eq https
access-list creovpn permit ip host 192.168.1.71 172.20.4.0 255.255.255.0
access-list creovpn permit ip host 192.168.1.65 10.0.0.0 255.255.255.0
access-list victorvpn permit ip host 192.168.1.65 10.0.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 44.44.177.122 255.255.255.248
ip address inside 192.168.1.200 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 172.20.4.100-172.20.4.120
ip local pool syssrc-pool 172.20.3.100-172.20.3.120
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list creovpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 44.44.177.125 192.168.1.3 netmask 255.255.255.255 0 0
static (inside,outside) 44.44.177.124 192.168.1.2 netmask 255.255.255.255 0 0
* static (inside,outside) 44.44.117.116 192.168.1.10 netmask 255.255.255.255 0 0
* static (inside,outside) 44.44.117.117 192.168.1.11 netmask 255.255.255.255 0 0
access-group int-outside in interface outside
route outside 0.0.0.0 0.0.0.0 44.44.177.121 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set secureset esp-3des esp-sha-hmac
crypto map victoreppmap 10 ipsec-isakmp
crypto map victoreppmap 10 match address victorvpn
crypto map victoreppmap 10 set peer 44.44.177.114
crypto map victoreppmap 10 set transform-set secureset
crypto map victoreppmap interface outside
isakmp enable outside
isakmp key ******** address 44.44.177.114 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh 44.44.37.8 255.255.255.255 outside
ssh timeout 5
console timeout 0
vpdn group creo accept dialin pptp
vpdn group creo ppp authentication mschap
vpdn group creo ppp encryption mppe 128
vpdn group creo client configuration address local pptp-pool
vpdn group creo pptp echo 60
vpdn group creo client authentication local
vpdn group syssrc accept dialin pptp
vpdn group syssrc ppp authentication mschap
vpdn group syssrc ppp encryption mppe auto
vpdn group syssrc client configuration address local syssrc-pool
vpdn group syssrc pptp echo 60
vpdn group syssrc client authentication local
vpdn username creoaccess1 password *********
vpdn username syssrc password *********
vpdn enable outside
terminal width 80
Cryptochecksum:d205b7d1b0c408d975986b0919eae8a0
: end

pixfirewall(config)#  sh access-lists
Type help or '?' for a list of available commands.

pixfirewall(config)#  sh access-lists 
access-list cached ACL log flows: total 0, denied 0 (deny-flow-max 256)
            alert-interval 300
access-list int-outside; 9 elements
access-list int-outside line 1 permit tcp any host 44.44.177.125 eq ftp (hitcnt=12167)
access-list int-outside line 2 permit icmp any host 44.44.177.125 (hitcnt=3916)
access-list int-outside line 3 permit tcp any host 44.44.177.125 eq www (hitcnt=303)
access-list int-outside line 4 permit tcp any host 44.44.177.124 eq 3389 (hitcnt=35)
access-list int-outside line 5 permit icmp any any (hitcnt=4034)
access-list int-outside line 6 permit tcp any host 44.44.117.116 eq www (hitcnt=0)
access-list int-outside line 7 permit tcp any host 44.44.117.116 eq https (hitcnt=0)
access-list int-outside line 8 permit tcp any host 44.44.117.116 eq 3389 (hitcnt=0)
access-list int-outside line 9 permit tcp any host 44.44.117.117 eq https (hitcnt=0)
access-list creovpn; 2 elements
access-list creovpn line 1 permit ip host 192.168.1.71 172.20.4.0 255.255.255.0 (hitcnt=579)
access-list creovpn line 2 permit ip host 192.168.1.65 10.0.0.0 255.255.255.0 (hitcnt=865)
access-list victorvpn; 1 elements
access-list victorvpn line 1 permit ip host 192.168.1.65 10.0.0.0 255.255.255.0 (hitcnt=1031)

pixfirewall(config)# sh static
static (inside,outside) 44.44.177.125 192.168.1.3 netmask 255.255.255.255 0 0
static (inside,outside) 44.44.177.124 192.168.1.2 netmask 255.255.255.255 0 0
static (inside,outside) 44.44.117.116 192.168.1.10 netmask 255.255.255.255 0 0
static (inside,outside) 44.44.117.117 192.168.1.11 netmask 255.255.255.255 0 0

pixfirewall(config)# sh access-group
access-group int-outside in interface outside

0
jstewart21
Asked:
jstewart21
1 Solution
 
batry_boyCommented:
Given your netmask on your outside interface (255.255.255.248) and assuming it is correct, are you sure that you are using available public IP addresses in your range?

I would double-check to make sure that .116 and .117 are available addresses for your use.
0
 
jstewart21Author Commented:
To: Batry_boy
I will check.
James
0

Featured Post

The IT Degree for Career Advancement

Earn your B.S. in Network Operations and Security and become a network and IT security expert. This WGU degree program curriculum was designed with tech-savvy, self-motivated students in mind – allowing you to use your technical expertise, to address real-world business problems.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now