• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 529
  • Last Modified:

laptop Wiress fails when change SSID or add encryption to router

An old IBM laptop was connecting fine to a d-link di-624 router wirelessly. SSID was "default" and there was no encryption.

I changed the ssid and added wpa-psk. Then found out the laptop was old and used only WEP. so I changed wpa-psk to WEP.

When I tried to connect to the network, it never brought up the netork key dialog box -- instead, it said "Windows is unable to connect to the selected network".  But if I tried to connect to nehbor's networks, it did ask me for the network key.

Then it began not to see any wireless networks at all, off and on.  the signal strenght was high.

I dropped the firewall, and I removed encryptino from router. NO change.

So I installed a belkin usb wireless, it connected fine to the network. Until I added encryption back. THen no connect.

So I removed encryption and set the ssid back to "Default" nad uninstalled belkkin usb wireless.  Now the laptop connects fine again.

But we want encryptoin, and to change the name.

Waht could be causing this?
0
dgrrr
Asked:
dgrrr
1 Solution
 
SysExpertCommented:
1) Get the latest BIOS and drivers from IBM

2) Delete and recreate the network connection

3) DIable or remove any other Lan connections / and NICs

4) Use WEP for now, and with the latest drivers it may work


I hope this helps !
0
 
SysExpertCommented:
What IBM laptop Model ?

0
 
jekl2000Commented:
Depending on the age of the laptop and its drivers, it may only support 40 bit (called 64) encryption. If this is the case then your WEP key would need to be 5 alpha characters or 10 hex characters. 104 bit (called 128) uses 13 alpha or 26 hex.  There was a time when some would only work with an alpha key and some would only work with a hex key.  You can check this by using the 64 bit key in both alpha and hex and see if it works.  Some routers let you have 4 WEP keys and you selected the one you wanted to use. If yours has this, make sure the key selected is the one you intend to use for the laptop.

As mentioned, check for drivers updates also.

If WEP is your only option, it is more secure to use the open than the shared method. Shared transmits your key in plain text, open does not.
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
Here2HelpCommented:
Hey.

Are you using Windows XP?

A good place to start with is getting WPA2 installed (if it isn't already)
http://www.microsoft.com/downloads/details.aspx?familyid=662BB74D-E7C1-48D6-95EE-1459234F4483&displaylang=en
Check in your d-link to see if WPA2 is installed.  if it isn't then I suggest you update the d-link firmware.

Firmware is here: http://www.dlink.com/products/support.asp?pid=6&sec=0#firmware  (click on the correct image to download the file you need) D-link recommend you do this over a wired connection to your router as a safe precaution.

I personally recommend that you uninstall any third party software that looks after your Wireless settings and use the built in XP features.

Try setting it up as WPA2-PSK Date Encrytion:AES (in Networking connection>Wireless NIC properties>"Wireless Networks" tab.


Try out these settings, it may take awhile to connect so let it sit there, give it about 15min if it doesn't connect sooner. Go make a coffee and come back later.  You may get a "Limited or no Connection" box appear, right click on your wireless nic in Network Connections and choose "Repair".  Again wait for a connection.  This usually is the case with may WLAN!  Just give half a chance to do something.  If theres still no connection then there must be something else at play.
0
 
dgrrrAuthor Commented:
The laptop in question is a IBM thinkpad type 2372, Windows XP SP2.

Today I returned to the site, and I tried simply re-enabling the same ssid & security that I had done before (whic the laptop could NOT use):
channel 6
open system
wep enabled
wep 64bit
key type HEX
(There's only one key specified, not 4)

... AND it's working fine now, with NO other changes. Tthe laptop is connecting fine.  

So the question is -- Do I simply wait and see if the problem recurs, OR do I go ahead and do the drivers / bios / WPA2 updates you guys mentioned... I'm reluctant to change anything if the computer is working fine - espedcially and OLDER laptop like this.  (I've often seen simple updates cause nightmare tech issues)

What do you think?
0
 
dgrrrAuthor Commented:
PS -- does the fact that it's working now (for the time being) RULE OUT any of your suggested fixes?
0
 
SysExpertCommented:
I'm glad it is working.

I would not change anything in this case.
If you do decide to update, then I would definitely consider doing an image of the laptop drive beforehand.

I hope this helps !
0
 
Computer101Commented:
PAQed with points refunded (250)

Computer101
EE Admin
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now