We help IT Professionals succeed at work.

Read only attribute keeps resetting.

Medium Priority
3,798 Views
Last Modified: 2008-01-09
I have a Quickbooks installed on a Windows 2003 server. I have several users that remotely access the database (network version of Quickbooks). We keep having problems accessing the databes, and it always come back to them being marked read only. we've unchecked the read only box, and gone into the command prompt and set attrib -r on both Databases. When we check back later, the read only attribute is set again.

I've turned off inherited permissions on that entire folder, but something keeps tripping read only on those files. I cant find anything in Quickbooks itself that would do it, so I'm thinking it has to be something in Windows.

Any ideas on what could consistently set it read only?

Comment
Watch Question

Why don't you turn on auditing.  I believe that you need to audit "Object Access."  Unfortunately you need to audit for success and failure so its easy to fill up your security event log quickly.  make sure you're only auditing the files in question.

Author

Commented:
Turned on auditing. Nothing showing up yet. These show up in the security event logs right?
Yes - has the read-only bit changed?

Author

Commented:
I haven't been able to get back by there to check, and I can't get in remotely. As soon as I have an update I will post it.

Author

Commented:
Nothing is showing up in the auditing logs, but after some testing today, I can see the server itself has nothing to do with this.

Setup: We have the databases hosted on Server2003, QB Pro 2007 installed on the server and all 3 databases set on the server in Multiuser mode.  We have the Database Server Manager monitoring the databases so that it can 'serve' them properly.

I set Read Only attribue to off on all files in the DB folder. It stays off for a time. We noticed that when user A accesses Database 1, the Read Only attribute comes on on DB 3. If User B uses DB 1, the Read Only attribute comes on on DB 1. When User A gets out of DB 1, the RO attribute comes off of DB 3. When User B gets out of DB1, the RO attribute stays on. We rarely use DB2, so haven't done any testing on it. The Read Only attribute only sets on the DB files, not the other files in the folder.

We also noticed that after testing that the Database Server Manager was no longer monitoring the databases. We had to specify and rescan the folder to get it monitoring again. The service had not stopped or been restarted. It just stopped scanning/monitoring the databases (all are in the same folder).

The attribute settings make no sense here. How would User A opening DB 1 set the RO attribute for DB3?? We tested this several times, and it's consistent.

If UserB is in DB1, in Multiuser Mode, then User A can't get into DB1 and gets the Error -6177, Quickbooks can not open the path to the database. She can browse to it through the mapped drive, or by the open dialog in QB with no problem, but the error comes up the same.

I'm pretty much a Newby with QB, but this makes no sense at all to me.

Any ideas?
Don't know QB either.  This seems to be an application issue here.  I guess all you can do is call the app people or pose this question in another forum.  

Author

Commented:
Turns out the file attribute changes are normal. QB itself changes them depending on file usage. The mail problem was caused by a mapping error that I figured out and QB tech support had no idea. You have to map directly to the folder where the data files are kept, not a root folder with the data files in a sub folder. Once I remapped it, everything started working fine. Their tech support had no idea on that one. Figures.

PAQed with points refunded (125)

Computer101
EE Admin

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.