• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

Unable to start debugging on the web server

hi
i want to create a website with simple aspx pages on my local machine and then move to server.
when i run my application vs.net 2003 i get this error
Unable to start debugging on the web server

can someone guide me without providing links to the sites
0
samir25
Asked:
samir25
  • 7
  • 5
  • 2
  • +1
1 Solution
 
chinu1310Commented:
Even if that does not work.

Try these links.
http://www.experts-exchange.com/Programming/Languages/.NET/ASP.NET/Q_22679672.html?sfQueryTermInfo=1+debug+server+start+unabl+web

http://www.experts-exchange.com/Programming/Languages/.NET/ASP.NET/Q_21108788.html?sfQueryTermInfo=1+debug+server+start+unabl+web

Also try this.

Type "Unable to start debugging on the web server" this in search textbox of EE page and search within
EE. you will find solutions.
0
 
samir25Author Commented:
how can i do this one
Case 2: Please check whether Enable HTTP Keep Alives option of IIS is checked or not. If it is turned off, you may need to turn it on and try your debugging again.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
samir25Author Commented:
if you have to refer to links then pls dont answer in the post. i need some quick help that why i am asking here.
my enable http keep alives in turned on.

can anyone who actually knows how to solve this provide some feedback
0
 
renjurdevanCommented:
Make sure that you (current login user) are member of debugging user group

if not add you in debugging user group!!
Logoff and login try debugging


Regards
Renju
0
 
samir25Author Commented:
it is there in the debuggers users..any other SUGGESTION
0
 
renjurdevanCommented:
Can u Run a page with out debugging using Ctrl+F5?

Make sure that you are running your application in Debugg mode not in release mode!!

If no use aspnet_regiis -i from command prompt you can hav this exe from the framework root directory

still you find diificuly for debugging

Try attaching to the process (from Visual studio Tools menu) aspnet_wp.exe (check the view system processes) and then running your application from the web browser instead of by running debug mode.

Regards
Renju
0
 
renjurdevanCommented:
Can u Run a page with out debugging using Ctrl+F5?

If no use aspnet_regiis -i from command prompt you can hav this exe from the framework root directory

Make sure that you are running your application in Debugg mode not in release mode!!

still you find diificuly for debugging

Try attaching to the process (from Visual studio Tools menu) aspnet_wp.exe (check the view system processes) and then running your application from the web browser instead of by running debug mode.

Regards
Renju
0
 
samir25Author Commented:
Can u Run a page with out debugging using Ctrl+F5? yes i can
what next can i do to check
0
 
renjurdevanCommented:
Make sure that you are running your application in Debugg mode not in release mode!!

still you find diificuly for debugging

Choose Internet Options from IE Tools menu select Security Tab -> Selecelct Local IntraNet -> Click Custom Level and choose the logon option as automatic logon with current username and password!!

close your IDE .. Open it and try to debug!!
still no hope

Try attaching to the process (from Visual studio Tools menu) aspnet_wp.exe (check the view system processes) and then running your application from the web browser instead of by running debug mode.


Regards
Renju
0
 
samir25Author Commented:
i am running my applicatin in debug node
i did this also automatic logon with current username and password!!
clsoed my app and started and i STILL GET THE SAME ERROR
i am not sure how to do this
Try attaching to the process (from Visual studio Tools menu) aspnet_wp.exe (check the view system processes) and then running your application from the web browser instead of by running debug mode.

0
 
renjurdevanCommented:
Select Debug FRom IDE
select Process
check show system process select aspnet_wp.exe and attach

Regards
Renju
0
 
samir25Author Commented:
but how does it solve the problem? do you know how to solve this issue?
i can already see the website when i run without debugging. the point is not that.
0
 
Farhan KaziSystems EngineerCommented:
Try starting your application without debugging. If you still get an error, you have an error in your web.config file.

If above does not work then:
Click Start -> Run -> Cmd.exe
CD C:\WINDOWS\Microsoft.NET\Framework\ <version>

aspnet_regiis -ua
aspnet_regiis -i
aspnet_regiis -enable
0
 
samir25Author Commented:
absolutely wonderful...it worked...but can you tell me why u uninstalled and installed asp.net and what is this enable?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

  • 7
  • 5
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now