VPN client can't ping ASA5510

Posted on 2007-07-20
Last Modified: 2008-01-09
1. I cannot ping from my VPN client the host inside my LAN on  ASA5510, can you please check on my configuration and tell me what is wrong.
vpn : -------- ASA -----HOST IP :

2. What i would like at the end, is the VPN client to access ONLY some servers (IP : to 192.168.50) on my LAN

Please help

#sh run
: Saved
ASA Version 7.0(5)
hostname ciscoasa
domain-name mydomain
enable password oxHHVUhvm1EJfZCj encrypted
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address
interface Ethernet0/2
 no nameif
 no security-level
 no ip address
interface Management0/0
 no nameif
 no security-level
 no ip address
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
access-list inside_nat0_outbound extended permit ip
access-list cisco_splitTunnelAcl standard permit
pager lines 24
mtu outside 1500
mtu inside 1500
ip local pool vpnpool mask
asdm image disk0:/asdm505.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1
route outside 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
group-policy cisco internal
group-policy cisco attributes
 dns-server value
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value cisco_splitTunnelAcl
 default-domain value mydomain
username tel password xxxxx encrypted privilege 15
username vpnuser2 password xxxxxxxxx encrypted privilege 0
username vpnuser2 attributes
 vpn-group-policy cisco
username vpnuser1 password ccccc encrypted privilege 0
username vpnuser1 attributes
 vpn-group-policy cisco
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
tunnel-group cisco type ipsec-ra
tunnel-group cisco general-attributes
 address-pool vpnpool
 default-group-policy cisco
tunnel-group cisco ipsec-attributes
 pre-shared-key *
telnet inside
telnet timeout 5
ssh timeout 5
console timeout 0
class-map inspection_default
 match default-inspection-traffic
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
service-policy global_policy global
: end
Question by:aime14
    LVL 79

    Expert Comment

    Add these commands:
      isakmp nat-traversal 20
      isakmp identity address

    If this fixes the primary issue, then we can work on access restrictions.


    Author Comment

    Dear Irmoore,
    Thank you, i added the two commands, now it fixed.
    Please lets continue with the ACL
    LVL 79

    Accepted Solution

    Good. At least that is some progress!

    Here's what I would to do restrict access:

    \\-- create an object group that contains all the servers that you want VPn users to access:
    object group network VPNACCESS

    \\-- create an acl to allow this object-group to talk to the vpn subnet, deny all other local systems to talk to the vpn subnet, but allow all hosts everything else
    access-list inside_outbound permit ip object-group VPNACCESS
    access-list inside_outbound deny ip
    access-list inside_outbound permit ip any any
    access-group inside_outbound in interface inside

    \\-- Done! Just add/subtract individual IP's to the network object-group as needed.


    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
    I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now