We help IT Professionals succeed at work.

Windows 2000 Server - 320gb NTFS Hard Disk incorrectly recognized

LeighWardle
LeighWardle asked
on
Medium Priority
2,805 Views
Last Modified: 2013-12-05
Hi

I have just added a 320gb IDE Hard Disk to a Windows 2000 Server system.
The Windows 2000 Server OS runs from a 160gb IDE Hard Disk.

The newly added 320gb Hard Disk has been formatted as a single NTFS partition (when installed in a Windows XP system).

My problem is that the Windows 2000 Server system only sees that partition as a 120gb partition that is not formatted.
I am sure this is not a hardware problem, as I can boot this hardware using a Windows XP system that runs entirely from a CD-ROM. The 320gb NTFS partition is recognized When that OS is running.

I have tried un-installing and re-installing the 320gb drive, but that doesn't make any difference.

Regards,
Leigh
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
Windows 2000 needs at least sp2 (i think) to recognize disks larger than 137GB. so make sure you have all servicepacks installed. Some Bios's also need to be updated for larger disks to be seen, and some disks also have a jumper set which makes it show up as a smaller disk, but that usually is for 32GB.

Author

Commented:
Thanks, rindi, for the suggestions.

You say "Windows 2000 needs at least sp2 (i think) to recognize disks larger than 137GB".
But the main hard disk that runs the OS is 160GB, all 3 partitions on it are recognized OK.

The BIOS setup shows that the size of the second hard disk is 320gb.

Regards,
Leigh
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
A partitioned disk is no problem. The problems start if a partition is larger than 137GB. Anyway, there are no reasons not to have at least the last SP on windows 2000. if you have your Windows uptodate and you still don't see the complete disk, then there'll be a registry edit needed, but first verify that you have the latest servicepack or there is not much else to suggest.

Author

Commented:
Thanks, rindi, for your comments.

I just checked that my Windows 2000 Server system has SP4 installed.

I did a Google search and found this article:
http://techrepublic.com.com/5208-6230-0.html?forumID=101&threadID=221716&messageID=2228654
The article says " Go to run and type compmgmt.msc----open disk management right click on hard disks and click enable large disk support it will show correct size".
I tried that, but (although I am not sure exactly what " right click on hard disks" means - I did right click on "Hard Disk 0" and "Hard Disk 1" - neither gave "enable large disk support" as an option, just Properties etc.

By the way, I tried replacing the 320gb drive with a 160gb drive configured as a single NTFS partition - that was recognized OK.

Regards,
Leigh

Author

Commented:
Could this be relevant?

48-Bit LBA Support for ATAPI Disk Drives in Windows 2000
http://support.microsoft.com/kb/305098

Regards,
Leigh
CERTIFIED EXPERT
Most Valuable Expert 2015
Commented:
Check the following registry entry and change it if necessary. Also make sure that inside your cmos setup you have enable 48bit support, or LBA mode, or something similar, it isn't always called the same.

http://support.microsoft.com/kb/305098/en-us

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
correct

Author

Commented:
rindi, Thanks for your help, Regards Leigh
CERTIFIED EXPERT
Most Valuable Expert 2015

Commented:
your welcome
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.