We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Exchange 2003 OWA SSL Setup

DUKESBANK
DUKESBANK asked
on
Medium Priority
655 Views
Last Modified: 2011-09-20
Hello,

Our Exchange  2003  Server on a Windows 2003 SP2 Server,  and our IIS 6.0 are on the same Server.
I  have installed a SSL certificate on the default web site hosting  and followed the MSexchagne.org article on  SSL enabling for OWA.  When we try to access the HTTPS, we get the Security Alert for the certificate and we anwser yes, and then we get a HTTP 404 not found error.

The SSL certificate is valid until 2008.

When we remove the HTTPS requirement, http owa will work correctly.

Any Help in Troubleshooting this would be appreciated.

Thank You In Advance
Comment
Watch Question

Expert of the Year 2007
Expert of the Year 2006

Commented:
Is this a home grown certificate or a purchased certificate?
The require SSL option is just that - require SSL. It isn't a switch to enable or disable its use.
What do the IIS logs show?

Simon.
first.....do you have port 443 open in your router/firewall.  you will need that port to be open to access OWA through https://xxxxxxxxx.  because SSL requires port 443 and routes traffic through secure channel.

Author

Commented:
I am trying to get this working internally first, so I have been testing all internally so far.
  I noticed that in the default website that the SSL port has nothing in it.  Whe I put in 443 the default website stops and errors out, so I was wondering if this was normal behavior.

Thanks

Author

Commented:
Note:  I also do not get the default OWA Login Screen either.
Expert of the Year 2007
Expert of the Year 2006

Commented:
If the port isn't being entered then either something else is using the port or the certificate isn't being installed correctly.

Simon.

Author

Commented:
I have also noted that our IIS virtual directory for the Exchange folder is pointing to

\\.\BackOfficeStorage\localdomain.com\MBX  

A location that doesn't exsist on our Server or anywhere?  Should this be pointing to a specific folder?
I am wondering why we aren't getting the Logon.asp page?  

Thank You

Author

Commented:
The Certificate was Installed and working in March 2007.  The Certificate is good until March 2008 and I can view and enable the secure communications channel.

When I bind port 443 to the default web site I get the following errors:

Cannot register the URL prefix 'https://*:443/ExchWeb/' for site '1'. The site has been deactivated.  The data field contains the error numbe
&
Cannot register the URL prefix 'https://*:443/ExchWeb/' for site '1'. The site has been deactivated.  The data field contains the error number.

Thanks


has anything changed as far as the URL that you use to access OWA.  seems like the certificate points to a different URL than your original URL
Expert of the Year 2007
Expert of the Year 2006

Commented:
The Exchange virtual directory locations are virtual locations. The path you have posted is correct, so nothing to worry about there.

Something isn't correct with your virtual folder configuration.
I would reset the virtual folders and then attempt to set the SSL certificate again:
http://support.microsoft.com/default.aspx?kbid=883380 

Simon.

Author

Commented:
I have already reset the Virtual Directoris using method 1.  Should that have pointed the Exchange virtual directory to another location?  If so, what location should it point to?  

Thanks
Expert of the Year 2007
Expert of the Year 2006
Commented:
If you have reset the virtual folders then you should not have to do anything else with the virtual folder configuration. Method one is what I usually use.
Did the folders get created correctly?

Simon.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I found the problem.  Another application was using Port 443.  I was not able to find it using the Netstat -ano , but found it using the Current ports Utility, found at :

http://www.nirsoft.net/utils/cports.html

Thank You all for your help.
perfect....i am glad it worked out.
CERTIFIED EXPERT

Commented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I will leave the following recommendation for this question in the Cleanup Zone:
Accept Sembee's comment as answer

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

f_o_o_k_y Experts Exchange Cleanup Volunteer
Forced accept.

Computer101
EE Admin
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.