?
Solved

Exchange 2007 Mail Submission

Posted on 2007-07-20
9
Medium Priority
?
4,057 Views
Last Modified: 2013-11-29
Im standing up an Enterprise Exchange 2007 system and Im currently getting no mail flow between the mailbox servers and the hub transport.  Here is the error that keeps coming up 

Event Type:      Warning
Event Source:      MSExchangeMailSubmission
Event Category:      MSExchangeMailSubmission
Event ID:      1009
Date:            7/20/2007
Time:            11:08:41 AM
User:            N/A
Computer:      EXMS01-B
Description:
The Microsoft Exchange Mail Submission service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Ive tried the solutions listed in the website but it has not corrected the issue.  Let me give you a little background 
I currently have an Exch2003 Enterprise setup in domain ABC.com.  We are currently deploying another separate forest, which Ill call domain XYZ.com.  Both domains are connected by a two-way trust and there are not child domains in either domain.
I built an Edge, and Hub transport server.  The Edge is in the DMZ as a standalone server and not part of the XYZ domain.  The Hub and mailbox servers are behind the DMZ and are a part of the XYZ domain.  The Exch2007 system is on a different subnet than the DCs.
Im able to set up a connector from domain ABC (Exch2003) to XYZ (Exch2007).  Ive sent test messages and they were received by the Edge and Hub transport but never made it to the mailbox server.  

Any help would be appreciated.
0
Comment
Question by:GhostRyder2112
8 Comments
 
LVL 8

Expert Comment

by:Bird Dog
ID: 19534255
can you explain the current process for your mail now. ie comes in hits firewall from firewall hits......
0
 

Author Comment

by:GhostRyder2112
ID: 19534734
Mail flow is from Exch2003 BH server in ABC domain to Exch2007 HT server in XYZ domain.  There are no FW's involved in the mail flow right now.  I did have mail flow set to go through the ET server but then changed the flow since all mail is, for the time being, internal.
0
 
LVL 22

Expert Comment

by:ATIG
ID: 19541209
When you recieve the error above what are you testing

1. can you send to a user on 2007 from a user on 2007
2 can you send from 2007 -> 2003
2 can you send from 2003 -> 2007

Do you have a hub,cas, and mbx in the same AD site?

Do you have firewall on the mbx server?
Transmission bewteen the Hub and MBX is rpc traffic

Have you bounced the hub server?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 

Author Comment

by:GhostRyder2112
ID: 19543887
My answeres listed below -

1. can you send to a user on 2007 from a user on 2007
No
2 can you send from 2007 -> 2003
No
2 can you send from 2003 -> 2007
No

Do you have a hub,cas, and mbx in the same AD site?
Yes.  On all on seperate servers.
Do you have firewall on the mbx server?
No
Transmission bewteen the Hub and MBX is rpc traffic
Yes

Have you bounced the hub server?
Yes
0
 

Author Comment

by:GhostRyder2112
ID: 19573280
I found the resolution to this issue, or more importantly my particular issue.  The permissions were not set correctly in the GPO.  Once they were set mail started to flow.  Ive included the steps I took to find the solution below.


SYMPTOMS:   Mail sits in the outbox on newly installed Exchange Mailbox 2007 and Exchange Hub 2007 servers.
1.   Event ID 1009
------------------------
RESOLUTION:  Turned up Debug Trace Logging in EXTRA.exe on the Mailbox server for StoreDriver, and All Categories.   Stopped restarted the Microsoft Exchange Mail Submission Service, and waited for event to be logged in event log.

In the trace log we had this line:
SeqNo     TraceType     Component      Tag                    Message
24     Debug            StoreDriver    BridgeheadPicker       Found /o=XYZ/ou=Exchange Administrative Group/cn=Configuration/cn=Servers/cn=ServerName as the next server
25     Pfd                StoreDriver    MailSubmissionService  EMS 22427 SubmitMail for mailbox 00000000-0000-0000-0000-000000000000 at entry 64
44     Debug           StoreDriver    MailSubmissionService  Submission failed. Error: ServerNotAvailable, Diagnostic Information:Rpc Error 5

Using the Group Policy MMC go to Local Computer Policy / Computer Configuration / Windows Settings / Security Settings / Local Policies / User Rights Assignment.  Under Access this computer from the network make sure the following groups are added - Everyone, Administrators, Backup Operators, Power Users, and Users.
0
 
LVL 22

Expert Comment

by:ATIG
ID: 19573316
good to know.... Did you modify access this cmputer from the network right?
0
 

Author Comment

by:GhostRyder2112
ID: 19574348
I modified the GPO that was attached to the servers which pushed the settngs to the "Access this computer from the network" area.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 20980499
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question