Moved BES now no email!

Ok I have searched around a good bit before posting my question, and I have not found an answer to my specific problem.

I have just moved our BES to a new server on our domain.  The Exchange organization is the same as well as the domain.  I have run the BESSrpTest.exe and it returns a "Successfull" result.  

Here is my problem...I cannot send or receive emails from my Blackberry.  I do not know where to go from here, so I am hoping some of you might help.
r270baAsked:
Who is Participating?
 
BlackBerryLinks_comCommented:
The MAGT log will help but look only for the part with the problem ;-)

The permissions are View Only Administrative and Read As and Send As.
It is good explained in the Installation manual:
http://www.blackberry.com/knowledgecenterpublic/livelink.exe/Installation_Guide.pdf?func=doc.Fetch&nodeId=1363702&docTitle=Installation+Guide

But do not add the BESadmin account to the Administrator group.

The CDO.dll and MAPI32.dll must be in the Exchange directory on your BES. I have created a freeware tool what gives a lot information about your installation (including versions)
http://besinfo.bes-admin.com

Regards,
Bob

 
0
 
BlackBerryLinks_comCommented:
Are you using the same besadmin account? If not check the rights (Send As and Receive As). Check if the CDO.dll and de MAPI32.dll are the same version as your Exchange Server (Exchange is leading).
The stop the BlackBerry Router for 20 min.
If you have still problems, check if your SRP key is not blocked (if you move to another system you need to take some time before you start the BES on a new system. If it is to quick it is possible that RIM has blocked your SRP.

If you have no Technical Support contract by RIM you need to contact your supplier of the BES.

Regards,
Bob
0
 
r270baAuthor Commented:
I will try these and get back with you...thanks!
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
r270baAuthor Commented:
I do not find a CDO nor a MAPI32 in any of the RIM directories.  I only find them in Exchange or System32 directories.  

How do I check the rights (Send As and Receive As)?

I installed this under the Administrator account...was I supposed to install this under the BESAdmin account?

Should I just completely uninstall and reinstall (it is a small 10 user installation)?
0
 
BlackBerryLinks_comCommented:
Yes you need to run the BES under the BESAdmin services, so it is better to reinstall it with the BBESAdmin account. You may not have installed Outlook on the BES only the Exchange System Manager (depending on the version Exchange). The CDO.dll and MAPI32.dll in the Exchange directory is good, but check the versions.

Regards,
Bob
0
 
r270baAuthor Commented:
Ok I am going to uninstall BES under the Administrator login.  Then I am going to login as BESAdmin and reinstall the BES server.  What version should the CDO and MAPI32 be?
0
 
r270baAuthor Commented:
I have uninstalled BES as Administrator and then did a brand new install (creating a new database and all) under BESAdmin.  I have added all the licenses and users back to the server.  When I go to reactivate my phone I get nothing.  I do receive the emails from RIM in my inbox, but the BB sits there saying Activating blah blah blah....

What do I need to do now?
0
 
BlackBerryLinks_comCommented:
Did you wipe the BlackBerry device before Activating, or try a wired (USB on the BES or workstation with Desktop Manager) activation.

Regards,
Bob
0
 
r270baAuthor Commented:
How do I wipe the bb device now that it is not in BES server?
0
 
BlackBerryLinks_comCommented:
You can Wipe a BlackBerry device with:

Options/Security Options/General Settings and then from the menu Wipe Handheld

2nd option: Type 10 times a wrong (different) password.

Regards,
Bob
0
 
r270baAuthor Commented:
Will this stop my phone from working?  I assume it will kill all my contacts and emails correct?  Will I still be able to make a call?
0
 
r270baAuthor Commented:
Ok so I wiped my phone.  I got to an area with -80dbs signal strenght and 100% battery...still no go on the acctivation...any ideas?
0
 
BlackBerryLinks_comCommented:
Do a Wired Activation, do this with one of this:
1) On the BES, if it has a USB port
2) On a Workstation with the BlackBerry Manager installed
3) On a Workstation with the Desktop Manager installed.

Regards,
Bob
0
 
r270baAuthor Commented:
I have one more question...everytime I try to activate this phone, I receive the emails from RIM in my inbox.  This leads me to believe that my phone is contacting the RIM system and RIM is sending the email to the BES server.  Since it does not activate the phone however, do you think it could be a problem with my BES setup?
0
 
BlackBerryLinks_comCommented:
That is possible, but more possible is that you have not the set the right permissions for the BESadmin account. It is difficult to say. Most of the time the log file gives the clue.
Also you may not have Outlook installed on the BES, only the Exchange Manager (for your exchange version). Then check the CDO.dll and the MAPI32.dll if they are not have the same version as the Exchange server copy them from your Exchange server to your BES (and reboot).

Regards,
Bob
0
 
r270baAuthor Commented:
>That is possible, but more possible is that you have not the set the right permissions for the BESadmin >account. It is difficult to say. Most of the time the log file gives the clue.
What are the correct permissions?  Which log files would you like to see...I can post them.

>Also you may not have Outlook installed on the BES, only the Exchange Manager (for your exchange >version).
I did not have Outlook installed...I am installing it right now and will setup the BESAdmin account.

>Then check the CDO.dll and the MAPI32.dll if they are not have the same version as the Exchange >server copy them from your Exchange server to your BES (and reboot).
I am still unsure of how and where to check these 2 files at.  I only found the Exchange versions last time.
0
 
r270baAuthor Commented:
My versions for mapi32.dll and CDO.dll are the following:
mapi32.dll = 6.5.7638.1
CDO.dll = 6.5.7638.2

I have installed out but I cannot get the BESAdmin email setup (do I need to do that?)
0
 
r270baAuthor Commented:
Here is a snippet from the log:
[30053] (07/22 10:38:22.683):{0x560} Retry start for user: /o=TSP/ou=First Administrative Group/cn=Recipients/cn=xxx
[30041] (07/22 10:38:22.683):{0x560} Starting handheld for Ron Wilson
[40704] (07/22 10:38:22.683):{0x560} MAPIMailbox::MAPIMailbox(2) ServerDN=/o=TSP/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=COMMSERV/cn=Microsoft Private MDB, MailboxDN=/o=TSP/ou=First Administrative Group/cn=Recipients/cn=xxx
[40739] (07/22 10:38:22.683):{0x560} MAPIMailbox::MAPIMailbox(2) - ResolveName[1] success for DisplayName='/o=TSP/ou=First Administrative Group/cn=Recipients/cn=xxx'
[40204] (07/22 10:38:22.683):{0x560} MailboxManager::GetMailboxSession - Using MAPI profile 'BlackBerryServer'
[20400] (07/22 10:38:22.699):{0x560} {xxx@xxx} MAPIMailbox::MAPIMailbox(2) - OpenMsgStore (0x8004011d) failed, MailboxDN=/o=TSP/ou=First Administrative Group/cn=Recipients/cn=xxx, ServerDN=/o=TSP/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=COMMSERV/cn=Microsoft Private MDB
[40720] (07/22 10:38:22.699):{0x560} MAPI call failed. Error 'The information store could not be opened.', LowLevelError 0, Component 'MAPI 1.0', Context 649
[40205] (07/22 10:38:22.699):{0x560} MailboxManager::CloseMailboxSession - closing session
[20154] (07/22 10:38:22.699):{0x560} User Ron Wilson not started
0
 
r270baAuthor Commented:
I just tried downloading the BESInfo.zip but when I try and open the zip (from 2 different computers) it says it is corrupt.
0
 
r270baAuthor Commented:
>But do not add the BESadmin account to the Administrator group.
Do you mean the servers local Aministrator Group?
0
 
BlackBerryLinks_comCommented:
No not a memeber of the Domain Admins. Please follow the steps in the installation manual....

I tryed to download besinfo.zip (first store it local) and had no problem to open it.

0
 
BlackBerryLinks_comCommented:
0
 
r270baAuthor Commented:
Thank you so much...it was the permissions.  I am activated an working!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.