?
Solved

I can't add a printer to a domain controller or Windows Vista machines

Posted on 2007-07-20
3
Medium Priority
?
1,560 Views
Last Modified: 2013-12-15
I can't add a printer to a Domain Controller.  It's Windows Server 2003 Enterprise;  I'm trying to add an HP LaserJet 4350 by running "Setup.exe".  The application launches, chugs for 20 seconds and then just disappears.

A similar failure happens on a Windows Vista workstation.  In that case, it came up to the "Install Printer" screen, and THEN went away.
The same printer installs just fine on an XP machine, same network, same (network) printer.l

(On the server) In the Event Viewer, there is an Application Error, which says:
Event ID 1000
Faulting application _hpcdb.exe, version 2.1.2.15, faulting module _hpcdb.exe, version 2.1.2.15, fault address 0x00046604.

Event ID: 4097 (Dr. Watson)
The application, C:\DOCUME~1\dwight\LOCALS~1\Temp\_hpcdb.exe, generated an application error The error occurred on 07/20/2007 @ 15:36:10.781 The exception generated was c0000005 at address 00446604 (_hpcdb)
0
Comment
Question by:Dwight Baer
3 Comments
 
LVL 13

Assisted Solution

by:dhoffman_98
dhoffman_98 earned 400 total points
ID: 19536534
I've run into loads of problems with the 4350 drivers on Windows 2003 servers. I haven't tried it on Vista yet, but with 2003 it was awful. Microsoft recommended removing the HP Print Processor from the system. I think it was called HPPRN3 or something like similar, but that doesn't really resolve the issue. We ended up opening cases with HP, but they ended up telling us to use different drivers... which actually worked. The problem though is when you try to do something with functions particular to that printer that the other drivers don't support.
0
 
LVL 1

Accepted Solution

by:
todoservices earned 1600 total points
ID: 19536549
donot add printer using setup.exe, use havedisk in printer setup
0
 

Author Comment

by:Dwight Baer
ID: 19536695
Awesome, thanks todoservices!  And thanks dhoffman98 for being "first" with your contribution!
Procedure (for my own future reference):
1.  Double-click "Add Printer" in the Printers and Faxes window.
2.  Specify a Network Printer
3.  Choose "Connect to a printer on the Internet".  I knew this printer's IP address, so what I used was:
http://192.168.0.158"
The only catch with this method of adding a printer is, its name shows up as "NPI612E34 on http://192.168.0.158"  Not very informative to the average user on my network.  I'll have to research a way to change that name.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question