Unrecognized USB & PS/2 Keyboard/Mouse Coupled With File Access Issues

Posted on 2007-07-21
Last Modified: 2012-08-13

Please help!  I am currently running a home-built system with 4 hard drives, one of which is new.  I have installed Windows XP Home on the new disk in an attempt to migrate my primary drive to the new one.  It has run smoothly without problems for a number of days, through my normal install process.  However, following minor overclocking to my dual-core AMD Opteron CPU and voltage changes in the BIOS to the system fans, the computer crashed on multiple occasions as I determined a stable level of operation.  The crashes often took place while I was playing Grand Theft Auto: San Andreas, a system intensive PC game.  Following the latest crash, I am no longer able to log onto Windows.  I am a seasoned PC builder and have not come across these symptoms before.


From the Windows Logon screen (Welcome screen disabled), my administrative user name, Zimtok5, appears in the user box, and the password cursor is blinking in the password box.  However, despite keyboard operation in the CMOS boot screen, neither a USB nor Serial keyboard will respond to entering text into the password box.  Hence, I am unable to log onto my one and only profile (an administrative account with a password).   Also noteworthy; the light on my USB mouse is powered as the system is loading, but this dies once the Windows logon screen comes about.  Also, attempting to boot the machine from my Windows XP Home CD will not work, as the keyboard will not interrupt the Windows boot sequence when I am prompted to Press any key to boot from CD&..

To diagnose this problem, I launched Windows from my old install on my old hard drive by swapping the SATA cable targets around on the motherboard.  Through Windows Explorer, I was able to look at the data included on the new drive.  I was able to view all the Windows systems files and everything looked in working order with one exception: my account profile.  The folder E:\\Documents and Settings\Zimtok5 (my administrative user account on the 'new' drive) was inaccessible when accessed from Windows run on my old hard drive.  Is there a possibility that this profile has become corrupted from a crash and if so, how can I retrieve the data within this folder?  I have searched through the Microsoft Help and Support website for an article with similar problems without avail.

Any assistance would be greatly appreciated.


I have spent the last few days since I wrote this help document trying to solve this same problem.  I have tried running through Microsoft Support article, "How to recover from a corrupted registry that prevents Windows XP from starting" (KB ID no. 307545).  I was able to use a PS/2 keyboard to get into my Recovery Console, as guided by the Support document.  From there, I proceeded to copy E:\windows\system32\config\system, ...\software, ...\sam, ...\security, and ...\default files to a 'tmp' folder and delete the original instances, replacing them with those from the windows\repair folder.  Restarting the computer, I was able to see that the Administrator and Owner login 'buttons' on the Windows XP Welcome screen, which I had previously had disabled for the Win2000-esque logon screen.  My 'Zimtok5' administrative user logon button has disappeared.  However, at this point no combination of attached peripherals works to operate Windows.  No response from any of the following: 2 x USB mouse, 1 x USB keyboard, 1 x PS/2 mouse, 1 x PS/2 keyboard.

By booting into Safe Mode by pressing F8 after POST, the machine logs into Windows, to a low-res background, 3 of my game icons appear on the desktop, but none of the folders, etc which were previously there.  None of my mice/keyboards work and the hardware manager pops up, apparently recognizing each device individually, but the hardware driver manager (name?) pops up and at this point, I am stuck.

Alternatively, by booting to my old local disk on my C:\ drive, I am able to view and modify all the Windows folder contents, etc. on my E:\ drive Windows install.  However, my administrative user account folder is inaccessible.  I have tried to run through various Microsoft Support documents, to no avail.  [example: "Folder is not accessible.  Access is denied." (KB ID no. 810881)]  Seemingly, because I am running Windows XP Home, I am unable to disable Simple File Sharing to view the Security tab for any of my drives, and thus I am unable to reset the permissions to the folders I need access to.  I have tried entering into Windows from my sole administrative account, but I am unable to see this 'mythical' Security tab, spoken about by Microsoft Support articles (written for WinXP Pro, it seems).

If any genius can help me wriggle out of this complex scenario, I would be enormously grateful!!!

Best Regards,
Brad (Zimtok5)
Question by:Zimtok5
    LVL 6

    Accepted Solution

    That's a lot of issues... :)

    Let's start with a simple one:  security tab for XP Home.  You can see this if you log in as Administrator in Safe Mode (which you can only do from your old install, but that's OK).  You can also get a utility to allow it to be seen all the time:

    Once you have that, you should be able to modify the permissions on the new drive profile folder you need access to.

    If you use your PS/2 keyboard, can you boot from the CD?  If so, go and do an install repair (proceed as though you are going to do a new install, but when you choose the drive that already has your new installation on it you will be asked if you want to install to a different directory or to reinstall/repair the existing one) over your new installation and see if that helps.  It should reinstall all the WIndows files while leaving your profiles and programs intact.

    Author Comment

    Thanks for the response, IconoclastX.

    I'll go give that solution a shot.  I'm going to download that app from the Lockergnome website and give that a shot, then I'll try the Repair Windows install like you mentioned.  I'll see how that works and then I'll post again with the results.

    It is a lot of problems, isn't it?  Quite a convoluted scenario.  I've spent an easy 100 hours on this over the last 6 days...  Going a bit mental, I'll admit.

    Back soon.  ; )

    Author Comment

    Well, I was able to log onto the computer in Safe Mode as "Administrator", with no pass, on my C:\ Old Local Disk Windows install.  I could finally see the Security tab!  Didn't need the utility you'd offered, but downloaded it for future use anyway!

    Score 1 point for IconoclastX.

    Now, I'll run the Windows Repair utility after I give copying that restricted access folder again.

    Back soon.  ; )

    Author Comment

    Copying those previously restricted files worked like a charm after the permissions were changed.  Saved the entire contents of My Documents. (the only folder which had permissions problems due to the previous passworded state)

    Will do the Windows Repair next... just waiting for those few hundred gigs to copy over.  ; )


    Author Comment

    Well, the Windows Repair seems to have repaired a few things... PS/2 mouse/keyboard combo now works.  I've reinstalled the drivers for my Logitech USB mouse/keyboard to see if that will bring them to life.

    So, saved the files but the Windows Repair seems to have wiped out all of my Program installs from the Add/Remove Programs list... any way to give this the *hint* that they're still on the drive?  Will I need to reinstall all of them?

    Author Comment

    After all that, I'm going to have to reformat, but at least I got my critical data out of there first.

    Cheers for the support.
    LVL 6

    Expert Comment

    Hey, sorry to hear you're ending up at a format.  The WIndows installation repair usually doesn't affect installed programs, so something else must have done a number on it.  It's probably best you had  to reinstall anyway if that's the case, just to be safe.

    Glad to be of assistance. :)

    Author Comment

    Actually, due to problems I had with the network and the symptoms I experienced, I suspect the Sasser.worm virus got me.  It's alright, I don't end up worrying as long as my data is not lost.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now