Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Can't get dpr-1260 to work with linux

Posted on 2007-07-21
10
Medium Priority
?
1,907 Views
Last Modified: 2013-12-15
I recenlty switched from the D-Link DP-311 wireless print server to a DPR-1260 print server.  I connected the print server to a HP OfficeJet 5600.  I am able to get the printer to work through the router on a windows machine, but unable to on the linux boxes.  I have connected the printer manually to a linux box with success.  I have turned off wireless on the print server to rule that out.  I have LPR/LPD enabled as well as Raw TCP.  I have tried using the same URI that I used with the DP-311, but it is not working.  The URI's I have tried are as follows:

lpd://192.168.0.10/lp

socket://192.168.0.10:9100

socket://192.168.0.10:515

I have found the following error digging through logs:

"Remote host did not respond with data status byte after 300 seconds"

I have also updated the firmware on the print server.

Does anyone have any advice on where to go from here?

Thanks,

Bryan
0
Comment
Question by:kntgtaid
  • 6
  • 4
10 Comments
 
LVL 27

Expert Comment

by:Nopius
ID: 19544524
Someone already solved this problem: http://ubuntuforums.org/showthread.php?t=207005

"using Dapper, this is all fixed now. I held the reset button on the print server until the lights reset (about 10 seconds) then connected using the browser to the default 192.168.0.10
Setup the networking/wireless and updated firmware from Dlink
Installed printer using the System Settings > Printers menu at 192.168.0.10:port# where the port was listed on the web control page for the server.
works fine now."

0
 

Author Comment

by:kntgtaid
ID: 19546457
I am not using Ubuntu, so this is not working for me.  I am running Slackware, and just using CUPS to connect to the print server.  I am however, trying to apply their advice, and will keep you posted.

Thanks

Bryan
0
 

Author Comment

by:kntgtaid
ID: 19583611
I have  been doing some more investigation.  I ran nmap on the print server and found:

root@laptop:/var/log/cups# nmap 192.168.0.10

Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2007-07-27 22:05 CDT
Interesting ports on 192.168.0.10:
(The 1656 ports scanned but not shown below are in state: closed)
PORT     STATE SERVICE
80/tcp   open  http
515/tcp  open  printer
9100/tcp open  jetdirect

I then ran lpinfo:
root@laptop:/var/log/cups# lpinfo -v
network socket
network http
network ipp
network lpd
direct scsi

Since the printer has been set to 9100, so I need to use jetdirect/appletalk, which used the uri of a socket.  The URI I am now trying is:

socket://192.168.0.10:910

Still no luck...

Bryan
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 27

Expert Comment

by:Nopius
ID: 19589323
Is your printer accessible via WiFi (when you have done nmap scanning)?

I suppose that wireless printing is not enabled. But I have no such device and even don't know how it's WEB interface looks.
0
 

Author Comment

by:kntgtaid
ID: 19589439
Currently I have the print server running as a wired print server.  I wanted to take wireless out of the equation as a possible problem.  I am starting to think it is cups.  I am trying to figure out how to get cups to have jetdirect as a valid network when I run lpinfo.  I thought by forcing the URI to use the 9100 port it would resolve the issue, but it hasn't.
0
 
LVL 27

Accepted Solution

by:
Nopius earned 2000 total points
ID: 19589501
>  I am starting to think it is cups.

What manufacturer did you choose in CUPS?

If you may provide access to you printserver via Internet, I may try to connect it to my server from here. If it's possible (map it to external IP), all private info you may send me to email (you may find it in my profile). If not, I don't know how else I can help you.

0
 
LVL 27

Expert Comment

by:Nopius
ID: 19590468
> I wanted to take wireless out of the equation as a possible problem.

I tested your configuration and found, that your D-Link printserver have unconfigured wireless settings.

To configure wireless you should:
1) Follow DPR web admin page: Setup (top menu) -> Wireless settings (left pane)
2) Turn On "Wireless On/Off"
3) Choose a _correct_ network from the list of available networks "Wireless Network Name (SSID)" (you haven't perform this step)
4) Choose an "Infrastructure mode" On
5) Choose "Super G mode" as disabled (later you may try different choices)
6) Choose "Security Mode" WPA or whatever you use
7) Enter WPA key
8) Save config and reboot D-Link

If d-link is not a part of _existing_ wi-fi network, then choose "Ad-Hoc", not "Infrastructure", then you may connect to a single host with wi-fi adapter.
0
 
LVL 27

Expert Comment

by:Nopius
ID: 19590496
BTW on wired ethernet it seems to be working.
You should check for test page in the printer itself.
0
 

Author Comment

by:kntgtaid
ID: 19597692
I rolled back the version of cups to 1.212.  I then verified that I had the foomatic scripts installed:

> cd /usr/bin
> wget http://www.linuxprinting.org/foomatic-rip
> wget http://www.linuxprinting.org/foomatic-gswrapper
> chmod 755 foomatic-rip foomatic-gswrapper
> ln -s /usr/bin/foomatic-rip /usr/lib/cups/filter/foomatic-rip

I was then able to use the URI:
socket://192.168.0.10:9100

I have noticed a 2 - 3minutes lag for printing the document, but I can live with that.

Thanks Nopius!

Bryan
0
 
LVL 27

Expert Comment

by:Nopius
ID: 19597904
kntgtaid, thank you for points.

BTW, I also tested this URI: lpr://192.168.0.10/Officejet5500 and it was also working, but for me it takes longer time to print then with socket:// URI. On LAN the situation may be different.

Officejet5500 - is a queue name, visible on DPR STATUS web page.

I also noticed a lag, but it may depend on a content of your print job. Pictures take longer time then pure text.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses
Course of the Month15 days, 2 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question