• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 179
  • Last Modified:

wrong email ID

HI:
     I have created a user in Lotus Domino as following
jhon/MR/domain/com

after some days the user shifted from one department to another and his organizational name change as following by renaming the common name. The organizational name is the unique organizational so it can be changed via 'rename common name'.

so his new org name is jhon/IT/domain/com
when he sends email to outside domain instead the reciever see his international address the receiver receives the old ID as following.

jhon/MR/domain/com%domain@domain.com ((why this address is appearing))

please help me in this case so the receiver must see the following address.
jhon@domain.com.
thanks
0
aib_it
Asked:
aib_it
  • 5
  • 3
  • 2
  • +1
1 Solution
 
aib_itAuthor Commented:
this is happening for one person and also when i reply locally from my lotus notes i see two names
To: jhon/MR/domain/com
CC: jhon/IT/domain/com

it should be only one
0
 
SysExpertCommented:
1) Change the Mail owner in the Mail DB VIA THE TOOLS calendar-preferneces

2) Make sure that the internet name shows up OK in the Location DOC.

3) Check the log.nsf and adminp for any errors regarding the name change.

 
I hope this helps !

0
 
Sjef BosmanGroupware ConsultantCommented:
Is the user's Person document in the N&A-book (Domino Directory) correctly updated, under User name?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
qwaleteeCommented:
Do you really use /COM as your root org name?  I would not, but I also wouldn't really want to have to change it once widely implemented.

When you respond interbally via the REPLY button (bit not REPLY TO ALL), Notes normally examines two values:  FROM and PRINCIPAL.  If they are the same or principal is blank, then it just puts FROM in the new SEND TO.  If they are differentm then it puts PRINCIPAL in the new SEND TO and FROM in the new COPY TO (cc).

Similarly, when the SMTP outbound message is created, Notes looks at the same two values to determine who you are, and therefore how to form your Internet address.  This dance is a little more ocmplicated, because there are really a lot more factors involved -- are you letting the server or client determine internet address? Do you allow aut-formed Internet addresses?  In your case, I believe the CLIENT is forming Internet addresses, and it thinks that user is sending a message from SOMEONE ELSE'S mail file.  Therefore, the client thinks it should not use the user's own address, but that other user's, so it tries to create an address that should work for the user.  Unformatunately, it #1) is wrong, this is really the user's own mail file, and #2) it is doing a messy job or forming the address.

The way the address is bring formed is to take the Notes user name, and trying to include your NOTES INTERNAL DOMAIN NAME in the address localpart.  It separates the user name and the Notes domain name with a per cent sign.

SysExpert's first suggestion is probably all that is needed to repair this, so that PRINCIIPAL and FROM end up matching, and neither the user's client nor the recipient client (you when you reply to his messages) nor the server have any confusion.
0
 
aib_itAuthor Commented:
sjef_bosman:
       yes the user name in the person document is updated properly and even i deleted the old ID and created the new ID and linked the old document. But still the same, Is it possible that there is something in the client side so the old files are still remaining as after making the new ID i reset up the client notes.but still the problem is the same.

qwaletee:
   You are right while sending the email i can see that following
username/Old_ou/domain/domain
sent by username/New OU/Domain/Domain
I am not using /COM it was just example.

SysExpert:
i have checked the calendar-preferneces it is OK as required to be.It is only with this user not with others.

guys still the problem is the same need your help.
0
 
aib_itAuthor Commented:
qwaletee:
  As you have mentioned that user may be sending emails from other users mail file,  user is not sending from other users mail file but when he clicks over new memo it seems that it is sent from others email address see the following
username/Old_ou/domain/domain
sent by username/New OU/Domain/Domain
So now why it is saying that sent by normally this statment will occur when email is sent from other user's mail file.

I am not using /COM it was just example.
0
 
SysExpertCommented:
1) That happens when the Calendar preferences ( owner ) do not match the ID used.

SO it looks like the Calendar preferences are not set correctly.

Are you sure he is using the correct database ?


0
 
qwaleteeCommented:
Try the following FROM THE USER WORKSTATION:

Press Control-M (causes Notes to open a memo in the default mail file for the user)
Check whether it has a SENT BY value or not
Choose EDIT -> PROPERTIES
Change FIELD to DATABASE
Check the server and filename

In the second and last steps, what do you see?  Does it match expectations? Please post the exact information here, and don't try to obscure it or make it generic.  I don't think you'll ge a demerit for posting a serv name or user name here.

Next, from the same memo, choose TOOLS -> PREFERENCES
Click CHANGE, and bypass the warning
Choose YOUR NAME from the address book
Save preferences
Go to your workstation
Open the user's mail file
Verify that preferences show your name, and, if so, change it back to the user's new name... VERIFY THAT IT HAS THE NEW OU!
Save the preferences if you have changed them, otherwise, cancel
Restart the user's workstation
Go to preferences
Has it changed back? If so, do Control-M and see if the values are now as expected

Finally, if none of the above works:
Take user's ID file to your workstation
Make a new location pointing to the user's mail file
Switch to the new location
Change to the user's ID
Create a memo
Does it match expectations?  If so, then it is a problem at the user's workstation.  If not, it is a problem with the user's mail file.
0
 
aib_itAuthor Commented:
qwaletee:
Thanks you very  much for all your help which was really urgent.I really appreciate and the solution was the following
Next, from the same memo, choose TOOLS -> PREFERENCES
Click CHANGE, and bypass the warning
Choose YOUR NAME from the address book
Save preferences
Go to your workstation
Open the user's mail file
Verify that preferences show your name, and, if so, change it back to the user's new name... VERIFY

Thanks to SysExpert as well for help.
Thanks to Expert Exchange
Regards
0
 
qwaleteeCommented:
Sounds as if the name really was wrong.... maybe it looked OK, but somehow, it was "messed up" and did not exactly match the user name.  By changing it (to your name) and changing it back, the problem was resolved.

Does that seem to be the case?
0
 
aib_itAuthor Commented:
yes there the OU was still old and as i changed to correct one it got OK.Thanks
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now