Printing Locally via Remote Desktop

Does anyone know how I configure my home computer so that I can print locally when using remote desktop. The printer that I am using at home is a HP laserjet connected via a print server.  When connecting to my office computer (via remote desktop) I do not see the printer.  I have alreadt installed the drivers for this printer on my office computer.  
jpasquarellaAsked:
Who is Participating?
 
Rob WilliamsCommented:
If connecting using a VPN please advise and let us know what VPN client you are using. If not:

To set up printing with remote desktop:
-On the users workstation when they start the remote desktop connection client, click the options button, and then go to the local resources tab. Check the box for printers and save.
-the drivers for the printer have to be installed on the computer to which you are connecting, assuming they are not native to the operating system. Do not install the printer on the computer to which you are connecting but rather; on the "server" computer, open printers and faxes, on the menu bar go to file, server properties, add, and point to the diver .inf file. You will have to download the drivers first to a temporary folder. If you do this remotely, you should log off and back on before trying to print
-if still having problems, again on the computer to which you are connecting, go to printers and faxes, on the menu bar go to file, server properties, ports. Look at the port type. If it is a Dot4, you will need to use the following Microsoft fix: http://support.microsoft.com/default.aspx?scid=kb;en-us;q302361
-if it is an option, often connecting the printer to another local computer and sharing it, then connecting to the share rather than having it attached locally, often resolves the problem. If you are using a VPN client this is not always possible, due to routing issues.
-if you are using a USB printer, though it usually works (some multi-function units do not), Microsoft does not officially support USB printing through remote desktop sessions. Vista is supposed to resolve this, though it doesn't help you now.
-avoid PCL6 drivers with terminal services
-Microsoft has released an updated version of the Remote desktop Connection (ver 6) which should be more compatible with USB printers. Certainly offers more USB options, assuming these are compatible with existing O/S's.
http://www.microsoft.com/downloads/details.aspx?familyid=26F11F0C-0D18-4306-ABCF-D4F18C8F5DF9&displaylang=en
0
 
☠ MASQ ☠Commented:
Are you printing to a USB port?
If so it may actually be worth physically installing the printer in your office, checking it works locally there and then plugging it back in at home so that your RDC client uses an active port on your office PC to send the print queue from.
0
 
jpasquarellaAuthor Commented:
Will Remote Desktop work with a printer server on the client computer?  I have purchased a HP LaserJet P2015dn at home and want to print locally when I am connected to my work computer in the office.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Rob WilliamsCommented:
Yes it will. But as mentioned, the drivers have to be installed on the server.
0
 
jpasquarellaAuthor Commented:
Question- Do I install the print driver for the server (Windows 2003)  or the host computer that I am remoting into?  The machine that I am remoting into has Windows XP Professional on it.
0
 
Rob WilliamsCommented:
Server 2003 driver, though they are often the same as XP.
0
 
jpasquarellaAuthor Commented:
You are correct the 2003 driver also includes Windows XP.  Okay I have now installed the driver as per your instructions on the server.  Do I need to do anything on my office computer regarding the setting up of this printer? Will my office computer automatically find the printer now that the driver is on the server during the remote session from home so that I can then print locally (from home)?
0
 
Rob WilliamsCommented:
-On the users workstation when they start the remote desktop connection client, click the options button, and then go to the local resources tab. Check the box for printers and save.
0
 
Rob WilliamsCommented:
Thanks jpasquarella.
Cheers !
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.