• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1719
  • Last Modified:

Diskpart - Stretch partition issue

I have just used Dell Open Manage Server Administrator to extend a hardware RAID5 array. I now need to extend the partition using diskpart but i recieve an error when listing volumes:

DISKPART> list volume

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     C                NTFS   Partition     68 GB  Healthy    System

The disk management services could not complete the operation.

DISKPART>

I should have a D drive underneath the C system partition.


This is very similar to the following case:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22096372.html

However i was on Server Administrator 5.0 and i have now upgraded to 5.2 without luck.

I have even tried adding another disk to the array and reconfiguring again with the Server Administrator 5.2 but this still hasnt solved my issue.

I have check that the virtual disk service is running.

Any thoughts?

0
thegewse
Asked:
thegewse
  • 5
  • 3
1 Solution
 
ezatonCommented:
Try removing the Dell Open Manager (or Raid Manager), and try using diskpart again. When done, reinstall the raid manager. I have had issues with it and diskpart in the past.
0
 
rindiCommented:
Diskpart works for dynamic disks, and dynamic disks shouldn't be used on a volume where C is. Try a 3rd party tool like bootit-ng to manipulate your partition. Generally I don't really see a requirement to change the size of C: you should rather partition your disks and make sure C only holds the OS and nothing else. For that you would just use diskmanagement to create a new partition and then you can put the data there.

http://terabyteunlimited.com/
0
 
ezatonCommented:
Diskpart can extend partitions on basic disks too:
http://support.microsoft.com/kb/325590

Also, on Windows 2003 (and newer, I assume) you can extend a partition on a converted dynamic disk.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
thegewseAuthor Commented:
Thanks for the good responses..

Ill remove open manage tonight and see if diskpart works after that.

Im trying to extend the D: drive which is not a system partition or contain any OS files..

0
 
ezatonCommented:
Good luck. Let us know how it went.
0
 
thegewseAuthor Commented:
Resolved!

I removed Open Manager but that still did not solve my issue.

I then started experimenting with other diskpart commands.. "list volume" does not work.. but "select volume 1" did.. so i was able to select the disk that the list command could not display..

I then tried the "extend" command.. and it completed successfully.

Hopefully this helps someone in my situation..

Ps. I am working on a 1.3TB array but i would expect Windows 2003 to be able to handle that..

Thanks for everyones contributions
0
 
ezatonCommented:
OpenManage causes these problems. I will try to find an article about it, but I don't promise I would be able to do so.
If you have installed your server without the openManage, you would have avoided this problem. You can try - setup a Dell server without the openManage and test DiskPart on it. Now add the OM and try again.
0
 
thegewseAuthor Commented:

Hi Ezaton

I have around 15 Dell servers all with open manage, the rest can all perform a "list volume" without issue..

Very strange.

Perhaps its the latest versions that are having issues.

Ill award points as you have pointed me in the right direction..
0
 
ezatonCommented:
Thanks, and good luck.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now