Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2328
  • Last Modified:

XBOX 360 does not get all DNS info from Vista PC (wireless network)

I have a problem getting my PC running VISTA to assign a IP Address to my Xbox360.
I am trying to use a wireless connection using Asus SOLO wireless. When I do my network test on my Xbox, it shows that Wireless setup has passed. It is up and running can both are connected. However, the SOLO is not providing DNS infomration. Interesting enough, I so see that a IP address has been assigned for the Xbox360. The DNS stuff like gateway and Primary DNS, etc. is all blank so my guess is that my VISTA DHCP is not sending enough information (for some reason). The Solo wireless shows that DHCP *is* enabled. Could it be a subnet issue? I do not know how to move forward and solve this issue.
Can someone help me?
0
quatune
Asked:
quatune
1 Solution
 
pseudocyberCommented:
Are you sure your xbox is pulling the wireless connection from YOUR wireless and not a neighbor?
0
 
quatuneAuthor Commented:
When you set up the Xbox network, it looks for Wireless AP it sees. I set up my AP network name as Senju-PC-AP. This is the one I direct it to. Anyway, I dig a bit deeper and found that my XBOX is not the issue. It is just asking for IP, DNS and other network information. The problem is my Asus  WiFi-AP Solo that is part of the Asus P5W DH Deluxe MOBO is not creating a IP or any network info correctly.
The title is now a bit mis-leading since we need to concentrate on solving my WiFi-AP setup. If we get this solved, then Xbox (or any other wireless client for that matter) will get the proper network Assignments.

The Asus WiFi-AP Solo is not providing a DNS because no DNS is showing up. How can I fix this? The manual says I can manually setup the IP address and other network info but the window does not show up.   I am going to play around a bit more and see what I come up with.

One thing, Is if I connect a lan cable directly from my PC to Xbox, I have no problem. It is only when I try this dam wireless device. That at least tells me, my PC *can* deliver DNS info but not via WiFi-AP Solo.
Anyway, I guess I need a Asus WiFi-AP Solo expert? Anyone?
0
 
☠ MASQ ☠Commented:
Is it just these two devices that form the "local network"?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
quatuneAuthor Commented:
Yes. I know what you are thinking. Create a static IP and netmask on both ends manually? I might do that as a last resort but the DHCP *should* work if setup propertly. Maybe it is an abstract thing like updating my Bios on my Asus but probably not. The fact that I am getting proper wireless authentication and connection tells me the layer 1 is fine. It is Layer 2 on my WiFi-AP side is where I believe we need to look.
0
 
☠ MASQ ☠Commented:
Agreed but this issue is probably with Vista and its default security for what it sees as a public wifi network.  Treating your set up as simply sharing Internet access between a desktop with an AP and a WiFi enabled laptop, you need to force Vista into Access Mode for the ad hoc WiFi connection and the the Network and Sharing Centre switch from Public to Private network.  This of course relies on Fixed IPs between the two devices but the XBox will pick up the DNS settings from your shared internet provider connection.

This is probably a bit garbled as I'm rushing out of the office but I hope you get the general concept.

(Also this only works with the latest Vista compatible drivers for the Asus Solo board)
0
 
quatuneAuthor Commented:
Does anyone have docs or a step to step guide in setting up a desktop with an AP and a WIFI enabled device in VISTA? I do not know how to force Vista into Access mode of an ad hoc WIFI connection and switching from Public to Private network sharing Centre switch in Vista.  I procedure in how to do this would really help.
0
 
midustouchCommented:
1. Click on start button
2. type "network" in search box
3. Choose "Network and Sharing Centre"
4. Click on customize, change network to Private from Public.

0
 
quatuneAuthor Commented:
Please close this issue.
I ended up creating a LAN home network with xbox360. I never got wireless to work but MASQUERAID: provided me a good reply.
0

Featured Post

Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now