• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 627
  • Last Modified:

Fink & latex. sty path?

Hello,

I have a MacOSX with Fink installed.

Using Fink, I have installed latex (default place: /sw/bin/latex)

Which is the path where latex is looking for the .sty files?

I have tried several places without success, including /sw/share/texmf-dist/tex/latex/


DAvid
0
dportabella
Asked:
dportabella
  • 5
  • 5
1 Solution
 
ravenplCommented:
I don't know, but maybe You can find it by Yourself straceing the latex?

strace latex file.tex 2>&1 | grep ".sty"
0
 
dportabellaAuthor Commented:
ravenpl,

I didn't know about "strace". You mean this project, right?
http://sourceforge.net/projects/strace/

I downloaded it, however it seems that it is not compatible with MacOSX.

any other idea?

----------------
> ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-apple-darwin8.10.1
checking host system type... i686-apple-darwin8.10.1
checking for supported operating system... NO!
configure: error: operating system darwin8.10.1 is not supported by strace

0
 
ravenplCommented:
Try ktrace instead of strace?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
NopiusCommented:
Also BSD systems may have 'truss' instead of 'strace'.
0
 
dportabellaAuthor Commented:
I have tried ktrace,
and I find out the config file used: /sw/share/texmf/web2c/texmf.cnf

Here are the directories that latex is searching:
TEXMFMAIN = /sw/share/texmf
TEXMFDIST = /sw/share/texmf-dist
TEXMFLOCAL = /sw/share/texmf-local
TEXMFSYSVAR = /sw/var/lib/texmf
TEXMFSYSCONFIG = /sw/etc/texmf-config
TEXMFHOME = $HOME/Library/texmf
TEXMFVAR = $HOME/.texmf-var
TEXMFCONFIG = $HOME/.texmf-config
TEXMF = {!!$TEXMFCONFIG,!!$TEXMFVAR,$TEXMFHOME,!!$TEXMFSYSCONFIG,!!$TEXMFSYSVAR,!!$TEXMFMAIN,!!$TEXMFLOCAL,!!$TEXMFDIST}

------------
I have placed ucs.sty (and related files) to /sw/share/texmf-dist/tex/latex/ucs/
However, latex still does not find ucs.sty.

I've seen that there is an option of latex that helps you trace the directories it is looking:
latex -kpathsea-debug=255 test.tex

With this, I can see that latex is looking into that directory, but for some reason it does not find the file:
++++++++
...
kdebug:kpse_normalize_path (/sw/share/texmf-dist/tex/latex//) => 1
kdebug:hash_lookup(ucs.sty.tex) => (nil)
kdebug:hash_lookup(ucs.sty.tex) => (nil)
kdebug:hash_lookup(ucs.sty) => (nil)
kdebug:hash_lookup(ucs.sty) => (nil)
...
++++++++
I even have tried to put a simple file as /sw/share/texmf-dist/tex/latex/iucs.sty
but latex does not find it.


What can be the problem??

0
 
dportabellaAuthor Commented:
Nopius,
Can you please tell me where to download "truss"?
It is not installed in my system, nor in the Fink database.
0
 
ravenplCommented:
truss is solaris/bsd related. Since Your is macosx, truss will not work as well. Those 3 tools (truss ktrace strace) do same thing on different OSes.
0
 
ravenplCommented:
You have tried
/sw/share/texmf-dist/tex/latex/ucs/ucs.sty or /sw/share/texmf-dist/tex/latex/ucs.sty
The latter should work. Also not it has to be lowercase filename...
0
 
dportabellaAuthor Commented:
Yes, I have tried both:

/sw/share/texmf-dist/tex/latex/ucs/ucs.sty
/sw/share/texmf-dist/tex/latex/ucs.sty

they are lower case.
0
 
ravenplCommented:
Hmm, I don't know then. Maybe ktrace is showing the error latex is receiving from stat stat64 or open syscalls?
0
 
dportabellaAuthor Commented:
A colleague solved the problem.
>When you manually add files to your TeX tree you must always
>run some program that will reindex your tree. On my system (Linux) it is
>`texhash', on Windows I think it is `initexmf' or something like that. I
>don't know what it is on MacOSX.

ravenpl, the "ktrace" utility probed to be very useful also, so I will give you the points.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now