• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8498
  • Last Modified:

Activesync 3033 / Heartbeat errors

Hi all. I'm getting 3033 Activesync errors in event logs when users are activesync'ing.  I've googled around and got various articles about setting heartbeats, etc.  I have to say though; this isn't something i've EVER come across before (i.e. I've never had to much about with heartbeat settings before; my installs usually just 'work' :P ).  The error is below.  Do I have to add in heartbeat settings into the registry, or is this gonna be related to the PDA mobile carrier/device itself?  The firewall is an SP1 from Draytek on a fairly-standard Draytek router.


Event Type:      Warning
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3033
Date:            22/07/2007
Time:            01:34:00
User:            domain\user
Computer:      server
Description:
The average of the most recent [200] heartbeat intervals used by clients is less than or equal to [540].  Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and direct push technology.
0
Corcoran Smith
Asked:
Corcoran Smith
1 Solution
 
AbhijeetNigamCommented:
0
 
Corcoran SmithAuthor Commented:
thanks - i've already looked through this KB. I'm more-trying to find out WHY this is happening?
0
 
AndyARACommented:
Hi, did you ever find a solution to this? I am in the same position as you in that I don't have ISA server just a hardware firewall.
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
Corcoran SmithAuthor Commented:
Andy; adding in the heartbeat references to the registry does take care of this.  If you pop 'em in without values, it defaults them as 0, which works. then iisreset.
0
 
KiandraSSCommented:
Hi,

This is a question to the author of this question. In your last commnet you wrote: "Andy; adding in the heartbeat references to the registry does take care of this.  If you pop 'em in without values, it defaults them as 0, which works. then iisreset."
Can you please advise where did you add the reg key and what were the details?

Many thanks.
Hamada
0
 
GrayconCommented:
Some specifics that the article doesn't cover:

   1.  Open the registry on the computer hosting Exchange Server and navigate to the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters.
   2. Add two DWORD values: MinHeartbeatInterval and MaxHeartbeatInterval.
   3. Restart IIS Admin service

Set the DWORD values to decimal and enter number of seconds.  Most importantly, set the Max interval to less than your firewall HTTPS timeout (assuming you are using HTTPS connections).  I found it best to also change the HTTPS timeout on my firewall.  I read somewhere the Max value can't go beyond 59 minutes but I haven't verified this.
0
 
swappedsrCommented:
What doesn't make sense is my pix firewall is set to 1 hour by default, default heartbeat is set at 45 minutes, which is less than the firewall 1 hour timeout.  Doesn't make sense.
0
 
Corcoran SmithAuthor Commented:
This problem was with exchange and a cisco too, just for reference.
0
 
swappedsrCommented:
I did make the change, I added 1 for the decimal for MinHeartbeatinterval dword and maxHeartbeatInterval to 3540, which equals 59 minutes, which is less than the 1 hour default on the cisco pix 506e we have.  

Still don't understand though,  the default heartbeat intervals are hardcoded and are less than the default 1 hour on the pix. Please explain if you could, not understanding.
0
 
Corcoran SmithAuthor Commented:
  1.  Open the registry on the computer hosting Exchange Server and navigate to the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters.
   2. Add two DWORD values: MinHeartbeatInterval and MaxHeartbeatInterval.
   3. Restart IIS Admin service

when you create the values - don't put a value in - just accept the defaults. (it puts 0 from what I remember)

this worked for me on this particular installation..
0
 
swappedsrCommented:
It shows 1-3540 in that microsoft kb article, I will stick with these and see how it does.  Just wish I can find out how this will fix it as the default values exchange has set are under the firewall timeout period of an hour.
0
 
Corcoran SmithAuthor Commented:
Yeah - other considersation of course is that this was under a Cisco for me, too - the one and only time I've had this issue..
0
 
swappedsrCommented:
I will post back to let everyone know if this fixes my issue.  The only thing I can think of is that it isn't the MaxHeartbeat that is the important value, it looks to me like it is the MinHeartbeat value, which I moved to 1 sec instead of the default 60 seconds.  I think this is the case, since the MaxHeartbeat is hardcoded at 45 minutes by default, which is below the timeout on the cisco firewall already.  I shouldn't be seeing this error with the default maxheartbeat value of 45 minutes, period.
0
 
swappedsrCommented:
My changes didn't suppress the error messages.  Still getting them.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now