?
Solved

Cannot create a connection to data source 'dataSource1'.

Posted on 2007-07-23
6
Medium Priority
?
2,235 Views
Last Modified: 2008-01-09
Hello,

We are using SQL Server 2005 Report Services, Report Builder, and we've created a Report model and  deployed it to the server. When i run the a report builder on the network it runs fine. When I run the report from anywhere else,  I get the error below, when I press 'run report'.

*******************************************************************

For more information about this error navigate to the report server on the local server machine, or enable remote errors
----------------------------
Cannot create a connection to data source 'dataSource1'.
----------------------------
An error has occurred during report processing.

*******************************************************************

 I don't have a datasource called 'dataSource1'. We are allowing anonymous users to the report builder, and the system automatically prompts the user for a usernm/pwd for authentication. I'm not sure what we might have setup wrong here.  Has anyone seen this error before?
0
Comment
Question by:ms568
  • 2
  • 2
4 Comments
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 19562422
Even with a anonymous connection you need a SQL source.  When you deploy a report you HAVE to deploy a data source as well.
0
 

Author Comment

by:ms568
ID: 19565553
Ah I think I didnt describe that clearly. I do have a data source defined and it is linked to the report model, but the name is not 'dataSource1'. The data source does use is an impersonated windows account to access the database (since we have our database setup to allow only windows accounts to connect)
0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 19571859
Hmm, I would use Notepad to look at the XML source for the report.  Search it and make sure that there isn't a reference to dataSource1.
0
 

Accepted Solution

by:
ms568 earned 0 total points
ID: 19864956
The XML source did not have a reference to dataSource1.

What ended up being the problem was that in Report Manager, my user account did not rights to run a report. Two steps were necessary 1) create a system role with 'Execute Report Definitions' task rights. 2) Grant my app user rights to this system role.

To add this system role, from the Report Manger go to 'Site Settings', then 'Configure system-level role definitions'. Select Add New and check task 'Execute Report Definitions', and save.

To add the user to this system role, go to 'Site Settings', and 'Configure site-wide security'. Here add the app user and grant them permission to the system role created above.

This fixed my problem of not being able to run the report.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
Although a lot of people devote their energy toward marketing for specific industries, there are some basic principles that can be applied to any sector imaginable. We’ll look at four steps to take and examine how those steps were put into action fo…
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will get a basic understanding of what section 508 compliance can entail, learn about skip navigation links, alt text, transcripts, and font size controls.

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question