?
Solved

Exchange 2007 Relaying question?

Posted on 2007-07-23
12
Medium Priority
?
3,012 Views
Last Modified: 2008-01-09
We're using an Exchange 2007 server for our email...  I am using ASP.NET web pages to send email notifications.  To do that, the IIS server uses a simple SMTP conversation with the Exchange 07 server.

I am, however, getting an error:
The server rejected the sender address. The server response was: 530 5.7.1 Client was not authenticated

I suspect this has to do with our exchange server not allowing relaying... and that is a good thing, but I know in Exchange 03, it was possible to allow an exception.

In this case, I would like to add the IIS server (let's assume it's IP address is 192.168.10.200) to that exception list and allow any email from it specifically to be relayed to anyone from anyone.
0
Comment
Question by:lunanat
  • 6
  • 6
12 Comments
 
LVL 19

Accepted Solution

by:
aissim earned 2000 total points
ID: 19552154
This article should help ya get the necessary receive connector configured: http://msexchangeteam.com/archive/2006/12/28/432013.aspx
0
 
LVL 1

Author Comment

by:lunanat
ID: 19556691
I followed option 1 through each of it's steps, creating a new SMTP connector for the IP address of the server, allowing it to send to the Remote IPs 0.0.0.0 -255.255.255.255, then set the connector to be usable by the exchange server, and checked the "Externally secured" in the authentication tab.

Unfortunately, I still get the authentication error... it is not saying that I am not allowed to relay -I suspect that before I can attempt to relay, I need to allow anonymous senders.  Any ideas?
0
 
LVL 19

Expert Comment

by:aissim
ID: 19557704
When you say "allow it to send to the Remote IPs 0.0.0.0....." - are you talking about the 2nd screen shot in the article for Remote Network Settings? If so, that would be the place you enter the IP address of your IIS server; not the range 0.0.0.0-255.255.255.255.

If that doesn't work I would definitely try option 2.

Personally, in our test lab, I used option 1 and it worked fine and I have not tried option 2. But if option 2 works for you it's actually a bit more secure.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 1

Author Comment

by:lunanat
ID: 19557827
I removed the one I created, and tried the following:

For option 1:
New Connection
Name: MPB Connection
>next
Leave defaults
>next
Remove default of 0.0.0.0/255.255.255.255
Add 192.168.10.200 (IIS server)
>next
>new
>finish

>open properties of new connection
Set the Permission Groups to include "Exchange Servers"
Set the Authentication to use "Externally secured"

Then I tested it and got the same errors.

I then attempted step 2, basically just opening up the properties of the new connection and changing the Athentication to it's default, Permission Groups to "Anonymous Users" and then going to the Exchange Shell and typing in ||Get-ReceiveConnector "MPB Connection" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"||.

After that failed as well, I changed the cmdlet command to read ||Get-ReceiveConnector "MPB Connection" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Sender"|| and it still failed.
0
 
LVL 19

Expert Comment

by:aissim
ID: 19559277
When it's failing. Is it failing for all messages? Wondering if it works for an internal recipient but not an external recipient? I'm asking because you should be able to send internally without any hassles.

And is it still the same response/error you mentioned in your original question?
0
 
LVL 1

Author Comment

by:lunanat
ID: 19559312
The same error, yes.

The sender address and recipient address are the same, and that address exists (it is my email address).
0
 
LVL 19

Expert Comment

by:aissim
ID: 19559368
I just went back and looked at our Ex2007 virtual server and remembered something.....this new receive connector you're creating has to have it's own IP address (or you can use the Exchange server's default IP address and listen on a port other than 25, but that can get messy - I recommend a different IP).

So try adding another static IP (advanced tcp/ip properties of your local area connection), and set the local network settings of the receive connector to use this new IP.
0
 
LVL 1

Author Comment

by:lunanat
ID: 19559583
No dice..

-I went into the Ex07's TCP Properties, Advanced, then added the second IP address.
-Then I went to the DNS server and added a DNS for the new IP address
-Went into the Receive Connector in Ex07 and changed the FQDN to the new DNS entry
-Went into my source code and changed the name of the server to the new name

Same error:
The server rejected the sender address. The server response was: 530 5.7.1 Client was not authenticated
0
 
LVL 19

Assisted Solution

by:aissim
aissim earned 2000 total points
ID: 19560304
I'm crashing and burning on this one =) thought we'd have you going in no time; my apologies!

Try these two things and let me know:
1) Reconfigure the receive connector according to Option 1 (I think you switched the settings to option 2 earlier)

2) Change the Sender/From address to a fake address that does not exist in your org, but send To your valid internal address.
0
 
LVL 1

Author Comment

by:lunanat
ID: 19560356
Step 1 did it!

You're the Master for a reason I guess ;)

Heheh... it's been a long day.  Thank you kindly.
0
 
LVL 19

Expert Comment

by:aissim
ID: 19560371
Good to hear; sorry it took so long my friend - go get some rest!
0
 
LVL 1

Author Comment

by:lunanat
ID: 19560378
nah, no worries.  It was something that needed to be done, but not something that needed to be done ASAP... Just had that particular functionality disabled -people will be happy that it is now back online.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
There can be many situations demanding the conversion of Outlook OST files to PST format and as such, there is no shortage of automated tools to perform this conversion. However, what makes Stellar OST to PST converter stand above the rest? Let us e…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses
Course of the Month13 days, 18 hours left to enroll

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question