[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 338
  • Last Modified:

WIN2K Server mapping of Local Shared Drive...........

Windows Server 2000 SP4. The issue I am having is the mapping of a local shared drive. I have two hard drives in the computer; one C drive and one D drive. I am sharing the d drive and my third party application has scripting that uses that virtual drive letter to gain access to files. I am using the NET USE command to map the drive and give it the letter Z. So my D Drive shows up as a Virtual Drive accessed by Z:.

Under Service Pack 3 it was working fine but now since I upgraded to SP4 it appears to be broken. If I map the drive using the SUBST command I have no problem accessing the files, but after a undetermined time when using NET USE I can no longer access the files. I am trying to understand how NET USE is different from SUBST and the possible causes of this problem.
0
timsells
Asked:
timsells
1 Solution
 
wtrmk74Commented:
Net use is assigning an already located IDE to a letter notation of your choice like :Z

Subst is a DOS command used for assigning folder or directories to a notation of your choice like :G

So they can be used very differently but can be defined in the same way in a batch file or start up file.

How many clients are connecting to this drive letter?
0
 
SysExpertCommented:
I would also make sure that you delete the asigned drive letter before mapping it.

Alos, I do not like using Z: since it tends to be used for special programs. try using X or Y

I hope this helps !
0
 
oBdACommented:
Mapping the drive to itself will access the files through your TCP/IP stack.
Using subst will keep the access directly and should be a lot faster.
0
 
wtrmk74Commented:
oBdA
that was truly the answer to the question in the simplest terms.

0
 
timsellsAuthor Commented:
I am connecting 25 clients to this drive but not all at the same time. I have two hard drives and sharing the D Drive so that the files can be shared from all clients. Then I map the shared drive as drive letter that is consistent with the third party application I am using to access the files. This way the scripting is all the same since all the remote computers access the same path.

Thanks for all the feedback so far. The problem seems to be with accessing the files using NET USE and not SUBST. If I try to access the files with my batch file using NET USE, an undetermined amount of time later I can no longer access the file. I will then re-map the drive without re-starting the application or re-booting and I have no problem accessing the file. I then tried going back to NET USE again without restarting application or rebooting and same issue. The only way I could gain access to the file again using NET USE was to reboot the computer. I don't quite understand if some service is used when using NET USE or if it has something to do with the network or even how many clients are out they accessing the file.

Looking for the needle in the nay stack.

Tim
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now