• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 734
  • Last Modified:

**CISCO** Only 16 VLANS on a 2940? is there a way around?

We have 23 vlans currently. We would like to use a couple of little 2940's we have, but they only support 16 vlans, and when i put them into vtp server or client mode they revert to transparent:

SW_VLAN-6-VTP_MODE_CHANGE: VLAN manager chnging device from SERVER to TRANSPARENT.

We only need to use 3 or 4 VLANS on the switches. Is there any way of making this work? I have enabled VTP pruning, but that doesnt seem to have any effect.

Would it work if i manually set the vlans on the local switch
0
Wibble_
Asked:
Wibble_
  • 3
  • 2
1 Solution
 
yasirirfanCommented:
Yes it will work make sure the interfaces connected to switches are in trunk mode. Its better if you send the current config to trouble shoot whats the problem is

cheers

Yasir
0
 
Wibble_Author Commented:
With all due respect, the running config doesn't tell you much about vtp, but here is some more info that might be helpful:

Password:                                                                      
Maintenance>enable                                                              
Password:                                                                      
Maintenance#show running-config                                                
Building configuration...                                                      
                                                                               
Current configuration : 994 bytes                                              
!                                                                              
version 12.1                                                                    
no service pad                                                                  
service timestamps debug uptime                                                
service timestamps log uptime                                                  
no service password-encryption                                                  
!                                                                              
hostname Maintenance                                                            
!                                                                              
enable secret 5 *******                                  
!                                                                              
ip subnet-zero                                                                  
!                                                                              
no ip domain-lookup                                                            
vtp domain KCS                                                                  
vtp mode transparent                                                            
!                                                                              
spanning-tree mode pvst                                                        
no spanning-tree optimize bpdu transmission                                    
spanning-tree extend system-id                                                  
!                                                                              
!                                                                              
!                                                                              
!                                                                              
interface FastEthernet0/1                                                      
!                                                                              
interface FastEthernet0/2                                                      
!                                                                              
interface FastEthernet0/3                                                      
!                                                                              
interface FastEthernet0/4                                                      
!                                                                              
interface FastEthernet0/5                                                      
!                                                                              
interface FastEthernet0/6                                                      
!                                                                              
interface FastEthernet0/7                                                      
!                                                                              
interface FastEthernet0/8                                                      
!                                                                              
interface FastEthernet0/9                                                      
!                                                                              
interface GigabitEthernet0/1                                                    
!                                                                              
interface Vlan1                                                                
 ip address 10.10.10.101 255.0.0.0                                              
 no ip route-cache                                                              
!                                                                              
interface Vlan345                                                              
 ip address 172.16.254.28 255.255.254.0                                        
 no ip route-cache                                                              
 shutdown                                                                      
!                                                                              
ip default-gateway 10.10.10.1                                                  
ip http server                                                                  
!                                                                              
line con 0                                                                      
line vty 0 4                                                                    
 exec-timeout 720 0                                                            
 password *******                                                              
 login                                                                          
line vty 5 15                                                                  
 no login                                                                      
!                                                                              
ntp server 10.10.0.1                                                            
!                                                                              
end                                                                            
                                                                               
Maintenance#sh vtp status                                                      
VTP Version                     : 2                                            
Configuration Revision          : 0                                            
Maximum VLANs supported locally : 16                                            
Number of existing VLANs        : 5                                            
VTP Operating Mode              : Transparent                                  
VTP Domain Name                 : KCS                                          
VTP Pruning Mode                : Disabled                                      
VTP V2 Mode                     : Disabled                                      
VTP Traps Generation            : Disabled                                      
MD5 digest                      : 0x57 0x55 0x2A 0x54 0xA5 0xBD 0xF9 0xCB      
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00                      
                                                       
Maintenance#sh int status                                                      
                                                                               
Port      Name               Status       Vlan       Duplex  Speed Type        
Fa0/1                        connected    1          a-full  a-100 10/100BaseTX
Fa0/2                        notconnect   1            auto   auto 10/100BaseTX
Fa0/3                        notconnect   1            auto   auto 10/100BaseTX
Fa0/4                        notconnect   1            auto   auto 10/100BaseTX
Fa0/5                        notconnect   1            auto   auto 10/100BaseTX
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        notconnect   1            auto   auto 10/100BaseTX
Fa0/9                        disabled     1            full    100 100BaseFX    
Gi0/1                        connected    trunk      a-full a-1000 1000BaseSX  
Maintenance#sh cdp n                                                            
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge        
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone      
                                                                               
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID    
BBone2           Gig 0/1            162          S I      WS-C3550-1Gig 0/6    


Maintenance#sh ver                                                              
Cisco Internetwork Operating System Software                                    
IOS (tm) C2940 Software (C2940-I6Q4L2-M), Version 12.1(22)EA6, RELEASE SOFTWARE
(fc1)                                                                          
Copyright (c) 1986-2005 by cisco Systems, Inc.                                  
Compiled Fri 21-Oct-05 02:01 by yenanh                                          
Image text-base: 0x80010000, data-base: 0x80572000                              
                                                                               
ROM: Bootstrap program is C2950 boot loader                                    
                                                                               
Maintenance uptime is 20 hours, 18 minutes                                      
System returned to ROM by power-on                                              
System image file is "flash:/c2940-i6q4l2-mz.121-22.EA6/c2940-i6q4l2-mz.121-22.E
A6.bin"                                                                        
                                                                               
cisco WS-C2940-8TF-S (RC32300) processor (revision F0) with 20978K bytes of memo
ry.                                                                            
Processor board ID FOC1024Z478                                                  
Last reset from system-reset                                                    
Running Standard Image                                                          
9 FastEthernet/IEEE 802.3 interface(s)                                          
1 Gigabit Ethernet/IEEE 802.3 interface(s)                                      
The password-recovery mechanism is enabled.                                    
                                                                               
32K bytes of flash-simulated non-volatile configuration memory.                
Base ethernet MAC Address: 00:18:73:3E:08:C0                                    
Motherboard assembly number: 73-8783-06                                        
Power supply part number: 341-0085-01                                          
Motherboard serial number: FOC10231PJH                                          
Power supply serial number: HIC1022021C                                        
Model revision number: F0                                                      
Motherboard revision number: A0                                                
Model number: WS-C2940-8TF-S                                                    
System serial number: FOC1024Z478                                              
Configuration register is 0xF                              
0
 
Don JohnstonInstructorCommented:
According to this,

http://www.cisco.com/en/US/products/hw/switches/ps5213/products_data_sheet09186a00801973c8.html

It supports up to 128 VLANs.

Besides that, why do you need that many VLANs on a 10 port switch?
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
Wibble_Author Commented:
I dont need that many, but our vtp domain has 23. I was guessing that the switch was seeing that it (vtp domain) had too many and then reverting to transparent. I only need access to 2 - 3 on the swith itself. I just cant get the thing to go into client or server mode *sob*.
0
 
Don JohnstonInstructorCommented:
I really don't like VTP. Too many potentials for surprises. And with a switch that small, just put it in Transparent mode and create the VLAN's you need.
0
 
Wibble_Author Commented:
So that will work then?

/me dashes off to try...



It works! Yay!

Thanks everyone.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now