DNS issue on cisco pix firewall

Posted on 2007-07-24
Last Modified: 2010-04-09
This has got to be a simple setting but I can't find it.  I want users to be able to access Exchange 2003 outlook web access from the same address inside the office as outside the office.
Currently they use something like https:\\\exchange  From inside the office, this just hangs.  They have to use https:\\server1\exchange  which gets right in.
I can ping and it resolves correctly to the outside interface.
This works fine at another site but it isn't a cisco pix and less secure.  Is there a setting which will fix this?

interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password nnrqBhjuoeN1EujYGU encrypted
passwd 2KFQnbNIdI.45KYOU encrypted
hostname fw03.hw
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list outside_access_in permit tcp any host eq citrix-ica
access-list outside_access_in permit tcp any host eq 3389
access-list outside_access_in permit tcp any host eq www
access-list outside_access_in permit tcp any host eq smtp
access-list outside_access_in permit tcp any host eq citrix-ica
access-list outside_access_in permit tcp any host eq 3389
access-list vpnrule permit ip
pager lines 24
logging on
logging timestamp
logging buffered errors
logging trap errors
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside
ip address inside
no ip address intf2
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNpool
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list vpnrule
nat (inside) 1 0 0
static (inside,outside) netmask 0 0
static (inside,outside) netmask 0 0
static (inside,outside) netmask 0 0
access-group outside_access_in in interface outside
route outside 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
ntp server source outside
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map mymap client authentication LOCAL
crypto map mymap interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpngroup VPNtunnel address-pool VPNpool
vpngroup VPNtunnel dns-server
vpngroup VPNtunnel default-domain asterdog.local
vpngroup VPNtunnel split-tunnel vpnrule
vpngroup VPNtunnel idle-time 1800
vpngroup VPNtunnel password ********
telnet timeout 5
ssh outside
ssh inside
ssh timeout 60
console timeout 0
username mmorn password A9rtrlrLtdPYazx/ encrypted privilege 2
username rcals password i267OnOKyql2Vw5w encrypted privilege 2
username borise password breufodofi878787 encrypted privilege 2
Question by:fitzpab
    LVL 8

    Expert Comment

    first thing

    you are using https but you havent allowed the same anywhere in access list.

    second thing i need to know is that are the users trying to access this server from its public ip / nated ip?
    LVL 1

    Author Comment

    whoops....I haven't setup SSL yet.  It's actually http they are using
    They are able to access it from the public IP - domain name successfully from outside the office, but not inside the office.  
    LVL 8

    Expert Comment

    That is because they cant do that. local users will have to access it with local ip only.

    LVL 1

    Author Comment

    How do I allow them outside access?  Or modify my local dns so it redirects to it.
    Local domain is asterdog.local so just putting in an A record for outlook.asterdog.local doesn't work.
    Any ideas how to do this?
    LVL 79

    Accepted Solution

    >I want users to be able to access Exchange 2003 outlook web access from the same address inside the office as outside the office.
    We don't always get what we want. This is a design "feature" of the PIX.
    There are 2 ways around it.
    1. They have to use https:\\server1\exchange  what's wrong with that? You can setup internal DNS with an ALIAS record for server1 to make it
    2. If your public DNS server is physically outside your pix, you can use "alias" command or dns keyword in static (dns "doctoring")

    LVL 1

    Author Comment

    1. internal dns.   Not sure how to do this.  I have internal dns setup with asterdog.local   I have 2 forwarders going to the ISP's External DNS servers.  If I added a cname but that does the reverse.  I want users to be able to type in (internally) and it re-direct to http://server1   The default zone is asterdog.local.    I tried creating another zone for with these records, but when I went to a client workstation and ping tested, it still resolved to the external IP.
    2.  DNS doctoring.  I'll try this when I am next onsite.  I'm a little leary about re-directing IP's so I want to be able to be there and test everything and roll-back if there is a problem.
    I'll update this on Friday
    Thanks LRMOORE
    LVL 79

    Expert Comment

    You could always put a hosts file entry on the PC's outlook

    You could script this with login script to put in everyone's local hosts file.
    LVL 1

    Author Comment

    Thanks for the help.
    None of these really worked.  The DNS aliasing was a good idea but it didn't do the trick.
    The host entry was a good idea but that's a problem for the laptops in the public web.
    Thanks for trying.  I'll just have them do what they have been doing.

    Featured Post

    PRTG Network Monitor: Intuitive Network Monitoring

    Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

    Join & Write a Comment

    Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
    Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    24 Experts available now in Live!

    Get 1:1 Help Now