• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2884
  • Last Modified:

Windows Media Player playing Audio but no video in all formats

This is an exact echo of another posted problem, however, the solution does not appear to be the same:

"I'm running Win XP Pro & have some AVI/WMV/(others?) files that wont play the video (just see black screen) but they play audio.  The same files play fine on other W2K & XP PCs.  I checked the codecs and they seem fine.  I also tried updating Media Player on my XP PC, also tried re-installing Media Player 9, tried uninstalling & re-installing...no luck on this one problem XP PC.

Media Player on this PC also doesn't play .WMV files - no video - just audio."

I am also unable to play DVDs, experiencing this same problem

The resolution for this issue posted on EE was that the video was displaying on the secondary monitor. however, my computer is not set up to display on a second monitor. Also, If I try to select a different monitor, I am not given an option.

HELP PLEASE!!!
0
freshjuice
Asked:
freshjuice
  • 4
  • 2
1 Solution
 
MereteCommented:
2 things try updating your video drivers,
in wmp reduce the video acceleration bit by bit,  in tools options performance
download the codec pack
http://www.toggle.com/tag/codec.htm
do you have to use WMP?
upgrade to WMP 10 its better. dont touch the WMP 11 no good.
geat player
http://www.videolan.org/
cheers

0
 
freshjuiceAuthor Commented:
Thanks for the suggestions, Merete, I already follwoed them but they didn't help.

-->OKAY. the problem is definitely related to the display adapter. Under display adapters there are 2 listed. Both are the same: "Mobile Intel(R) 945GM/GU Express Chipset Family". What I did was disable the 2nd one and rebooted. When it came back, WMP 10 could now play MPG videos, etc but couldn't play the DVD still because the codec required TV OUt enabled or some such nonsense.

->When I downloaded the latest drivers from Intel and reinstalled, The 2nd dsiplay adapter reappeared, and the problem returned. :O

->I think the problem stems from this: when I go the Desktop graphics properties, it has selected Display one (the laptop screen), but Display 2 is listed as "(Default Monitor) on Mobile Intel(R) 945GM/GU Express Chipset Family".

->How do I set monitor/Dsiplay "1" as the Default Monitor instead of "2"????
0
 
MereteCommented:
Hi sorry for the late return are you aware that WMP does not natively support playing dvd's.
Do you have clone modes enabled? disbale clone mode or dual modes to single mode first.
"(Default Monitor) on Mobile Intel(R) 945GM/GU Express Chipset Family".<< this is for secondary monitor or number2
 
your curent monitor the number 1  then it would state "monitor name " such as LG or 700S on Mobile Intel(R) 945GM/GU Express Chipset Family
its best to boot to safemode uninstall your video card then reboot.
Or if you have nvidia or such boo tto  the advanced options tap F8 then choose start in vga mode in the very large desktop uninstall all the video cards listed then reboot and install one only. have your video card cd ready reboot and install to single mode display only.
When you enable clone or dual modes it will show several monitors in the device manager.
how do you have your desktop connected to the TV?
s-video?
Whats your video card please?

If you have a dvd rom drive it should have an install disc with either power dvd or winfast or some such these are the actual codecs needed for dvd playback. Then your WMP will play dvd.
If you dont have one of these you'll have to use another dvd player any codec packs just include a media player that supports dvd playback
The codec pack include media player classic which supports dvd playback using the dirctshow.

http://www.free-codecs.com/download/K_Lite_Codec_Pack.htm
vlc player
http://www.videolan.org/
I'll watch out for your reply this time i do live in australia so matbe on opposite times to you plus I work
Merete
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
MereteCommented:
just re-reading>->How do I set monitor/Dsiplay "1" as the Default Monitor instead of "2"????
default monitor is correct for 2.

r/click the desktop properties settings advanced your video card then look in the dual or clone modes
can you see your desktop okay on the second monitor
http://www.svideo.com/displayvideo.html
If your experiencing problems getting video on the 2ndary screen please post back your system specs laptop HP DEL etc
video card
what you have connected your laptop to a second monitor or tv
http://www.svideo.com/laptoptvout1.html
using what s-video or
http://www.svideo.com/
Some laptops also have a button on the keyboard with the functoin (fn) key to switch the output to the external monitor so you dont have to change settings in windows
0
 
freshjuiceAuthor Commented:
The solution to this problem:


1. I had to uninstall all display adapters in the Hardware device manager
2. I had to go into the registry and manually delete all Display Adapter references
3. I also had to delete all intel driver references in the registry under the heading "ialm"

After doing all this, I reinstalled the Intel graphic media accelerator. Problem solved.
0
 
MereteCommented:
yep thats sound about right, it can be tricky installing these graphics drivers if the previous were not removed correctly.
Often times it requires a complete format to clear out the problem.
cheers
Merete
0
 
KeeBlitzCommented:
Instead of reinstalling...An easy fix for this is to go to:
Tools - Options - Performance (tab) - Advanced (button)

Uncheck the "Use overlays" checkbox under Video Acceleration
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now