[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 702
  • Last Modified:

Windows 2003 connecting to CIFS share on linux by host name causes permissions issues

In Windows 2003 when connecting to a CIFS share on a linux box running samba and connecting by IP the share is always available - when connecting by host name after a time permission errors will prevent accesss. Messeges such as 'you do not have permissions.... to access this netwoek resource...

Using 'ping' as well as 'nslookup' from command line show that the IP is being properly resolved via DNS...

Thoughts plz
0
Karl66
Asked:
Karl66
  • 4
  • 2
1 Solution
 
RazwerCommented:
what does the log say about these errors?
0
 
stronglineCommented:
is all this in AD environment? what user ID did you use for accessing samba folder? In your samba configuration, there must be options for authentication, how were they set?
0
 
Karl66Author Commented:
security=ads
password server=*

I don't have the UID but the problem ocurs with any of the users with permission
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
stronglineCommented:
when access by ip works but not by name, besides DNS issue, it could also mean kerberos authentication is not working.

Join your samba server into domain by following the webpage below, section "Samba ADS Domain Membership", if you are using samba3+200x AD:
http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/domain-member.html#domain-member-server
0
 
stronglineCommented:
you will need to specify the kerberos realm name (domain name). Also, instead of using "password server=*, i will use a particular DC for testing (password server=fqdn of one of your DCs)
0
 
Karl66Author Commented:
Strongline -

Thank you for the response - I suspect you are close. The problem is that we have no problem connecting it is just the time-out issue that seems to be the problem.

Any thoughts?
0
 
stronglineCommented:
time-out is the symptom instead of the problem. did you create the machine acount in AD and join the samba server into the domain with command such as kinit? did you add parameter "realm=domain name"? you didn't mention in your post so i wonder....

i will focus on the confugrations rather than DNS
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now