Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Unable to find your qmail-newmrh file, specify --enable-qmail-newmrh ???? Im so stuck :(

Posted on 2007-07-25
5
Medium Priority
?
1,011 Views
Last Modified: 2013-12-15
Hi all

Im getting so stuck with this qmail installation, im stuck at the part where im about to configure vpopmail.

After you download and unzip this is the step:

cd vpopmail-5.4.13

./configure --enable-logging=p --enable-auth-module=mysql --disable-passwd --enable-clear-passwd --disable-many-domains --enable-auth-logging --enable-sql-logging --enable-valias --disable-mysql-limits

make && make install-strip

The first error I get is:

configure: error: Unable to find your qmail-newu file, specify --enable-qmail-newu.

Then I do a locate and then find this file in /usr/srv/qmail/qmail-1.03/

After that it then asks for newu

Now I did a locate and there is no newmrh

This is the main problem I am having,  errpr: Unable to find your qmail-newmrh file, specify --enable-qmail-newmrh

Im getting desperate now, ive looked at google for hours and nothing seems to match.

Anyone with knowledge of this file or could send me or advice please help :)
0
Comment
Question by:thechase22
  • 2
  • 2
5 Comments
 
LVL 14

Accepted Solution

by:
pablouruguay earned 750 total points
ID: 19568377
and your try this??

/configure --enable-logging=p --enable-auth-module=mysql --disable-passwd --enable-clear-passwd --disable-many-domains --enable-auth-logging --enable-sql-logging --enable-valias --disable-mysql-limits  --enable-qmail-newmrh



???
0
 
LVL 43

Expert Comment

by:ravenpl
ID: 19568571
usually /var/qmail/bin/qmail-newmrh or  /usr/srv/qmail/bin/qmail-newmrh
but try find it wit following command
find / -type f -name qmail-newmrh
0
 
LVL 1

Author Comment

by:thechase22
ID: 19572433
Hi Pablour I tried the extra thing you mentioned, enable-qmail-newmrh

But it still cant find it even when I specify.

THe only newmrh I have found is where you said raven in /usr/src/qmail/bin/ there is like 5 files

newmrhc
newmrh0
newmrh5

like the other files there should be one without the c or the 0 or 5 if you understand what I mean

But there isnt one
0
 
LVL 43

Assisted Solution

by:ravenpl
ravenpl earned 750 total points
ID: 19572528
> newmrhc
I assume newmrh.c

Have You tried the find command I provided? It qmail is installed, and there is no newmrh, then the installation is broken (newmrh is included in bare qmail distribution). Reinstall qmail.
0
 
LVL 1

Author Comment

by:thechase22
ID: 19572937
I tried that command yes and got this message.

find: /var/named/run-root/proc/21384/task: No such file or directory
find: /var/named/run-root/proc/21384/fd: No such file or directory
find: /var/named/run-root/proc/21385/task: No such file or directory
find: /var/named/run-root/proc/21385/fd: No such file or directory
find: /proc/21384/task: No such file or directory
find: /proc/21384/fd: No such file or directory
find: /proc/21385/task: No such file or directory
find: /proc/21385/fd: No such file or directory

You said assume newmrh.c. well I did the same, and it actually took it, but Im just concerned if its the right file, how comes the other files didnt use c, they just used the actual file if you get me.

But what is the C file?
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The main intent of this article is to make you aware of ‘Exchange fail to mount’ error, its effects, causes, and solution.
Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month11 days, 20 hours left to enroll

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question