• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3352
  • Last Modified:

Procurve Errors, Can't force N IC speed on PC's.

We purchased a Procurve 2900 about half a year ago. Recently I started checking it for errors as we experience delays at times writing or reading data from the file server ( This office about 20 users, 40 systems, W2K AD Domain, 98% XP Pro clients ).  Under status I discovered half a dozen systems were throwing errors stating either 'High collision or drop rate on port ...'  or 'Excessive broadcasts detected on port ...'.  The High collision errors are far more common.  

I started troubleshooting thinking these might be the cause of the intermittent delays. My first thought was to force both ends of the connection to Gig instead of leaving them on 'Auto' however I found that NONE of the NIC's involved would allow you to force them to a speed above 100 megs. Also discovered that when I forced a client to 100 or 10 Megs that client would lose connectivity with the LAN. Running IPCONFIG would return 'media disconnected'. Rebooting did not resolve it, only going back to 'Auto' would get the system to admit it ( all of our systems ) have a static IP and then allow connectivity to the LAN.

The other thoughts on tracking the problem down include trying other ports on the switch, trying a 3rd party NIC in the PC's involved, and trying other patch cables.  

I'm a little puzzled about not being able to force a speed on the connection. Many years ago that was how we ensured the auto settings were not screwing up.

Might anyone have a work around, or other ideas on identifying the cause of these few systems continuing errors?


Thanks

Paul
0
Bluewhale042399
Asked:
Bluewhale042399
  • 3
  • 3
  • 2
  • +3
3 Solutions
 
Jim_CoyneCommented:
Set the switch to full duplex, leave the PC as auto

Speed 1000
duplex full
0
 
Bluewhale042399Author Commented:
Hey Jim. That's how they are now. PC's on auto, Procurve most on Auto but have tried a few at 'Auto-1000' as that's as close as the switch comes to allowing me to force the speed.


paul
0
 
jburgaardCommented:
Prefered: auto-auto
If that does not work, then the fixed settings must be equal in both ends.
-as auto<->full will 'negotiate' to half<->full . Resulting in the errors described.

From ftp://ftp.hp.com/pub/networking/software/2900yl-MCG-0207-T_12_XX-Chap10-PrtStat-BasicCfg.pdf
switch-syntax: interface < port-list >
[speed-duplex < auto-10 |10-full | 10-half | 100-full | 100-half |auto| auto-
100 | 1000-full >]
(no auto-1000 as far as I can see)

Trying other patch cables =good idea
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
pseudocyberCommented:
I've found, for GigE, both sides HAVE
0
 
pseudocyberCommented:
Sorry.

I've found, for GigE, both sides HAVE to be Auto.
0
 
Jim_CoyneCommented:
High collision errors are an indication of duplex mismatch (not speed)

http://en.wikipedia.org/wiki/Duplex_mismatch
0
 
Jim_CoyneCommented:
You'll need to set the switch to 1000-half if you continue to get High collision errors w/ 1000-full
0
 
mkurtzhalsCommented:
Gig does not function @ half duplex.
0
 
Bluewhale042399Author Commented:
I'll try to set both sides for 100 if the other ideas don't pan out.
0
 
Mark WaldenInformation Security EngineerCommented:
Do you have any dumb hubs in the bldg.  because some hubs operate at 10/half they will cause a lot of collision.  See if you have any hubs hanging of the ports with high collisions.
0
 
Bluewhale042399Author Commented:
Turns out the switch is bad, possibly deteriorating. Moved one of the trouble PC's to another port and no errors. 2 daze later moved three more, same thing. Called HP who is overnighting a replacement out. FWIW the HP tech indicated that per RFC when using Gig ehternet at least one end of the connection must be set to 'auto'.

Thanks for the suggestions tho.


Paul
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

  • 3
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now