Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 448
  • Last Modified:

Problems upgrading from w.s.s2 to wss 3

Hello,

 

I am attempting an upgrade from wss2 to 3 on a single server running wmsde.

 


Upgrade fails at step 2 - An exception of type Microsoft.Sharepoint.Upgrade.SPUpgradexception was thrown. Additional exception information: action 3.0.2.0 of Microsoft.Sharepoint.Upgrade.SPConfigurationDatabaseSequence2 failed.

 

My Upgrade logs error say :

 

 Upgrading IIS settings . . .
[InitialFarmCreation] [3.0.2.0] [DEBUG] [7/24/2007 2:13:25 PM]: Creating an alternate access mapping for each iis web site.
[InitialFarmCreation] [3.0.2.0] [DEBUG] [7/24/2007 2:13:25 PM]: Adding an alternate access mapping for iis instance 1.
[InitialFarmCreation] [3.0.2.0] [DEBUG] [7/24/2007 2:13:25 PM]: Setting outgoing url http://webmail.kendrick.reading.sch.uk/ for zone Default.
[InitialFarmCreation] [3.0.2.0] [DEBUG] [7/24/2007 2:13:25 PM]: Setting incoming url http://127.0.0.1/ for zone Default.
[InitialFarmCreation] [3.0.2.0] [DEBUG] [7/24/2007 2:13:25 PM]: Setting incoming url http://webmail.kendrick.reading.sch.uk/ for zone Default.
[SPConfigurationDatabaseSequence2] [ERROR] [7/24/2007 2:13:26 PM]: Action 3.0.2.0 of Microsoft.SharePoint.Upgrade.SPConfigurationDatabaseSequence2 failed.
[SPConfigurationDatabaseSequence2] [ERROR] [7/24/2007 2:13:26 PM]: The IncomingUrl is already present in the collection.
[SPConfigurationDatabaseSequence2] [ERROR] [7/24/2007 2:13:26 PM]:    at Microsoft.SharePoint.Administration.SPAlternateUrlCollection.Add(SPAlternateUrl alternateUrl, Boolean fUpdate, Boolean throwIfExists)

 

 

The original v2 sharepoint existed in the default web server. Which was runnig successfully with a static html site/a front end mail-server and sharepoint was in a subfolder....(/sharepoint)

 

If it try to access my sharepoint central admin i get can't access gloabl confuguration data. I've no longer access to my original prescan logs. Prescan now fails saying can't find site (or similar)

 

Any ideas? How can i go foreward? or How can i go back? And start a gradual upgrade.

 

Thanks!
0
KenChrisB
Asked:
KenChrisB
  • 6
  • 3
1 Solution
 
Robbie_LeggettCommented:
Empty out the "Dependencies" and "Objects" table in the WSS Config database and run the wizard again.

Also, check whether the user account has rights to create a table in the master DB.
Give the account SA rights on the SQL server and re-run the wizard.
0
 
KenChrisBAuthor Commented:
How do i access the sql server management tools. ON WMSDE not sql server full?

0
Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

 
KenChrisBAuthor Commented:
Okay. Managed to clean out both tables. That i'm sure of

I've added a user/role called builtin/administrators to the users of database called master. And checked Create table permissions

I'm not sure if that is the same as what you're asking.

The upgrade is still failing in the same place. Should i be attempting to run prescan again?
0
 
Robbie_LeggettCommented:
Don't use the builtin\administrators account. What account are you running the upgrade under? Are you logged in as domainname\administrator? If so add that user as SA.
0
 
KenChrisBAuthor Commented:
have added my login to security as sysadmin and reemptied tables. Same problem when i run configuration.

0
 
KenChrisBAuthor Commented:
tried myself (as a member of group DOMAIN\administrators
and DOMAIN\administrator
All with the same result.
0
 
KenChrisBAuthor Commented:
Subsequently i gave up and uninstalled and went back to wss recreated a new sharepoint at same address.

i can't connect to the content database that i have, presumably because it's been at least part upgraded to wss vs 3.0

Have tried to restore my backups via stsadm.exe but i get message the backups are from a different version of sharepoint than the current server.

0
 
KenChrisBAuthor Commented:
Thanks Robbie, your solution worked in the end. But i also had a problem in iis settings

I had to remove the  local host setting  and then change the port settings on my existing website to 9999 (from 80), and then delete dependencies and objects table records.

And then the upgrade was able to proceed.
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now