• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 339
  • Last Modified:

Email DNS Lookup, Change reslove name HELP!

Hi Everyone,

I have an Exchange server and when my users send to and address ?@cfl.rr.com the messages do not go through.

I called the cfl.rr.com NOC and they have change their servers to deny messages without reverse DNS lookups.

My email is @ucumc.net and the ISP has the IP for the Exchange server listed for reverse DNS lookup, BUT when you reslove to the server you get the server name and not the Domain. Our Domain is being hosted at another IP address for our website.

Can I config my exchange server DNS to reply back to a reverse lookup with ucumc.net?
And How would I go about doing this?
  • 6
  • 5
1 Solution
You need to get your reverse DNS setup correctly. If your ISP is not willing to do that then you either need to route all of your email via the ISP or get a new ISP.

A reverse DNS lookup of domain.com is not valid.

However if your domain is ucumc.net then the problem is not a reverse DNS lookup.
It is your PIX.

Turn off fixup SMTP in the PIX as it is blocking the server announcing itself correctly.
Then open ESM, Servers, <your server>, SMTP. Right click on SMTP VS and choose Properties. Click on the tab delivery and then advanced. In the box FQDN enter mail.ucumc.net, ignore check dns and then apply/ok out.

SimNimbusAuthor Commented:
I have my exchange server at a different site at "mail.ucumc.net"
My domain "ucumc.net" is being hosted at
My ISP is using a Reverse Lookup for the exchange server site to

So when cfl.rr.com s mail server gets the email and does a lookup it sees a reply of hpserver1.ucumc.local and mail.ucumc.net

Then they kick back the email. because it does not come back as ucumc.net.

Am I getting this right?

How did you figure it was the PIX?
On the PIX question I recognised the response.
The remote site is not doing a lookup on ucumc.net, it is doing a lookup on what your server is announcing itself as and the IP address.

If your server announces itself as hpserver1.ucumc.local and the reverse DNS is mail.ucumc.net then it will fail the test. You need to make the changes I have outlined above. The link I included will show you how the internet sees your server.

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

SimNimbusAuthor Commented:
I did changes in the ESM and when I resend the email to cfl.rr.com I get a message that states

"An SMTP protocol error occurred."

I cheacked with my ISP and the reverse DNS is mail.ucumc.net

I asked them to change it to ucumc.net

I also  tried to change my PIX to ucumc.net

I'm not haveing any luck with any of these changes.

I may be going down the wrong path.

Any ideas?
Why are you changing your DNS to ucumc.net?
Why are you trying to change your PIX?

Everything else was setup correctly change back whatever you have tried to change.

The only thing you needed to do was disable fixup SMTP on the PIX and set the name in ESM. I have just repeated the test and fixup SMTP is still enabled.

Your reverse DNS is now no longer valid and needs to be corrected back to how it was before.

SimNimbusAuthor Commented:
ok, I made the changes back.

I'm going to have to take a class on how to follow directions soon if I don't get this right.

All I'm doing is entering mail.ucumc.net in the box FQDN, and ignore check dns and then apply/ok out.

Not hard, just have to do it right.

OK thank for your help so far Savant!

Have you done anything to the PIX?
That is the key thing because the PIX is getting in the way.

SimNimbusAuthor Commented:
No I have not done anything with my PIX.

I have to be honest I think there are 4 places I need to look when you say PIX.
Could you help he work out what is right.

I have PIX in the ESM
I have PIX Cisco firewall
I have PIX in the Cpanel for the domain host interface
And I have PIX with the ISP for the location of the Exchange server.

Where am I getting confused and what do I need to focus on?

What should I consider changing in the one I focus on?
Cisco PIX. Your firewall. You need to disable the fixup SMTP command.

No idea what the other PIX are, PIX in ESM is particualrly confusing.

SimNimbusAuthor Commented:
After guessing the user name and password, calling Cisco 3 times, uninstalling java and reinstalling java Uninstalling IE7 and installing ie6 and downloading a tftpd , installing PDM 3.0.4 and telneting into the PIX

I got into the interface and ........ thing I found the fixup SMTP.

It's under the Advanced Tab

I removed the only entrey in the listing so now there is nothing listed.

I'll know tomorrow  if it worked.

Just for the sake of saying it.

I hate people who do not document their network and servers!
SimNimbusAuthor Commented:
I'm guessing it worked. I had 41 messages in the Q ans now there are 17.

Humm. The listing in the SMTP Fixup was listed as 25, but I took it out, and noe there is nothing listed.

Well I hope it worked.

It looks like it did.

Thanks for your help Sembee!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now