Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco PIX 501 - Enabling SNMP Monitoring from outside (internet)

Posted on 2007-07-26
3
Medium Priority
?
776 Views
Last Modified: 2013-11-16
So, we have a Cisco PIX 501 that we have taken over monitoring.  However, we are trying to add SNMP monitoring via the outside interface in.  The current config I have on the PIX is included below with some omissions.  

What would be the proper config to add snmp polling from a specific ip, or subnet?  Say I want 1.2.3.4 to be able to snmp query the PIX via it's outside IP (WAN Interface).  How would I accomplish this?  Also, how would I add in the config that all traps generated are sent to 1.2.3.4 via the outside interface (Internet/WAN Facing Interface)

Config:

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXX encrypted
passwd XXXXX encrypted
hostname PIX-TEST-01
domain-name TESTING.COM
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.0.5.250 server1
name 10.0.5.251 server2
object-group service http_https tcp
  port-object eq www
  port-object eq https
access-list outside_access_in permit tcp any host XX.XX.XX.XX (replaced real address) eq https
access-list 105 permit tcp any host XX.XX.XX.XX(replaced real address) object-group http_https
access-list 105 permit icmp any any echo-reply
access-list 105 permit icmp any any source-quench
access-list 105 permit icmp any any unreachable
access-list 105 permit icmp any any time-exceeded
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside XX.XX.XX.XX(Replaced real address) 255.255.255.0
ip address inside 10.0.5.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.0.5.0 255.255.255.0 inside
pdm location server1 255.255.255.255 inside
pdm location server2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) XX.XX.XX.XX(replaced real address) server2 netmask 255.255.255.255 0 0
access-group 105 in interface outside
route outside 0.0.0.0 0.0.0.0 XX.XX.XX.XX(GW Replaced real address) 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.0.5.0 255.255.255.0 inside
snmp-server location NA
snmp-server contact NA
snmp-server community SNMPCOMMUNITY
no snmp-server enable traps
floodguard enable
telnet 10.0.5.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.0.5.10-10.0.5.50 inside
dhcpd dns server2
dhcpd wins server2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain testing.local
dhcpd auto_config outside
dhcpd enable inside
terminal width 80

Thanks!

0
Comment
Question by:cpttech
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 1500 total points
ID: 19581640
snmp-server enable traps
snmp-server host outside 1.2.3.4
access-list 105 permit udp host 1.2.3.4 interface outside eq snmp

Done.
0
 

Author Comment

by:cpttech
ID: 19631267
We are still not able to do snmp queries against the outside interface after adding these changes into the configuration. Any other suggestions? Thanks for your help.
0

Featured Post

2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Considering cloud tradeoffs and determining the right mix for your organization.
In this article, the configuration steps in Zabbix to monitor devices via SNMP will be discussed with some real examples on Cisco Router/Switch, Catalyst Switch, NAS Synology device.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question