Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1374
  • Last Modified:

CGI Timeout

1. I open a website built using ASP.Net in a Windows Server 2003.
2. Try to click a link which look like this http://website/virtual/cab/filename.exe.
3. I got this error message:
"CGI Timeout
The specified CGI application exceeded the allowed time for processing. The server has deleted the process."

I've tried this on other server, it is able to download the .exe file, and very fast.  I've increase the CGI Timeout period from 300 to 600 using IIS 6.0 Resource Kit Tools.

Are there any other setting that i can do on the server to avoid timeout ?

Thanks
0
fonglun
Asked:
fonglun
  • 3
1 Solution
 
William ElliottSr Tech GuruCommented:
do you have any specifics in the IIS logs?
C:\WINDOWS\System32\LogFiles\
or even more logging
http://support.microsoft.com/kb/324279

maybe a typo in the location?
0
 
fonglunAuthor Commented:
What actually can cause CGI Timeout when clicking on a link which will download an .exe file ?
0
 
William ElliottSr Tech GuruCommented:
not sure
http://supportline.microfocus.com/mf_kb_display.asp?kbnumber=22222&show

Problem
The following error message is displayed in the web browser before the CGI is completed:
---------------------
CGI Timeout
The specified CGI application exceeded the allowed time for processing. The server has deleted the process.
---------------------

The above error occurs after 5 minutes.

 
Resolution
The CGI timeout setting (not Connection Timeout) in Microsoft IIS server is defaulted to 300 seconds (or 5 minutes). If the CGI takes more than 5 minutes to complete, IIS will return the CGI Timeout error to the user's web browser and delete the process from the web server.

Here are the steps to change the CGI timeout setting in IIS 5.0 of Windows 2000 and IIS 5.1 of Windows XP:
1. Open Internet Information Services (Control Panel > Administrative Tools)
2. Expand Machine_Name (local computer)
3. Right-click on Web Sites
4. Click on Properties
5. Click on the Home Directory tab
6. Click on the Configuration button
7. Click on the Process Options tab from the Application Configuration window
8. Increase the number of seconds from CGI script timeout field
9. Click on the Apply button
10. Click on the OK button
11. Click on the OK button

It is now different the way to change the CGI timeout in IIS 6.0 of Windows 2003 Server. Actually, the Process Options tab is no longer available from the Application Configuration window.

Before you can change this setting, here are few things you need to do first:
1. Open Internet Information Services (Control Panel > Administrative Tools)
2. Right-click on Machine_Name (local computer)
3. Click on Properties
4. Check the "Enable Direct Metabase Edit" options
5. Click on the OK button
6. Close Internet Information Services
7. Install the IIS 6.0 Resource Kit Tools - this is available from the Microsoft Download Center at http://www.microsoft.com/downloads

Here now the steps to change the CGI timeout setting:
1. Open Metabase Explorer from Start > All Programs > IIS Resources > Metabase Explorer
2. Expand Machine_Name (local computer)
3. Go to LM/WESVC
4. Look for ID 6033 or CGITimeout under the Name column
5. Double-click the entry to edit its properties
6. Change the value
7. Click on the Apply button
8. Click on the OK button

For further readings, the IIS 6.0 online documentation is available at the Microsoft Windows Server 2003 TechCenter site. This can be accessed directly at http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS. The keyword or topic that addresses this issue is "Metabase". CGITimeout is a Metabase property. You will find everything about Metabase at IIS 6.0 Documentation > IIS 6.0 Technical Reference > Working with the Metabase (IIS 6.0).
0
 
William ElliottSr Tech GuruCommented:
http://support.microsoft.com/?id=185379

this actually looks more like what it could be?

CAUSE
The virtual directory containing the .exe file has the Execute application permission enabled. This causes IIS to attempt to run the .exe files in that virtual directory for the browser instead of downloading them.
Back to the top

WORKAROUND
To work around this problem, change the virtual directory application permission to None or Script. To do this, perform the following steps:
1. In Internet Service Manager (ISM), view the Properties page for the appropriate virtual directory in the Web site.  
2. On the Directory, Home Directory, or Virtual Directory tab, under Permissions, select either None or Script
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now