2003 server, multiple NICs, prevent DNS entries for specific NICs?

Posted on 2007-07-27
Last Modified: 2013-11-09

I have 2 2003 std servers with multiple HP NICs installed.  The configuration established sent the onboard NIC to the user's network while the other two NICs went to completely separate subnets for the sole purpose of iSCSI.   Using the MSoft iSCSI initiator I have configured failover between the two iSCSI NICS that resolve on said separate subnets and it works beautifully - hops across with no service interruptions.

user's subnet is 192.168.0.x
iSCSI 1 subnet is
iSCSI 2 subnet is
All the subnets are electrically isolated save for the 2003 servers in the middle.

So far so good.  However, I am experiencing a problem on the user's subnet as follows:
The only items on the iSCSI subnets are iSCSI devices, so users have no need to access them for any purpose.  Recently we noticed some users experiencing what seemed to be random slowdowns for network activities.  A trace shows that the NIC IP addresses for the iSCSI interfaces are being pushed to clients via AD DNS.  

I subsequently removed the "update dns" option from each iSCSI NIC and manually removed the 3.x and 4.x entries in the DNS servers but 20 minutes later they are back and messing with client PCs.

Apparently I have overlooked some aspect of this - how can I prevent those two iSCSI interface NICs from being handed out in DNS requests, short of manually entering the correct subnet server IP address ( in lmhosts?

Seems like I should be able to at least prevent DNS entries on an as-needed basis.  I think that is all it would take really.

Thank you,
Question by:miroka
    LVL 2

    Accepted Solution

    A simple solution woule be not to specify a DNS server for the Iscsi nic's. if the NIC doesnt have a dns server listed it cant register itself.
    One more thing in your network connections folder, click advanced, advanced settings and make sure that the iscsi nics arent on the top of the list and make sure your actual LAN connection is on the top. hope this helps.

    Author Comment

    Hi guys - sorry for the delay.  Got knocked out sick and this is 1st day functional again.

    Re-arranging the NIC list to ensure the actual LAN connections were on top seems to have finally resolved the issue.  Between the original post of my question and now I did find and remove the option for the NIC to include itself in the DNS lists overall.  However, the issue was not resolved until I changed the list order and rebooted one final time.

    Thank you,
    LVL 2

    Expert Comment

    cool im glad it worked!!!

    Featured Post

    Give your grad a cloud of their own!

    With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

    Join & Write a Comment

    Occasionally you run into the website or two that will not resolve properly using your own DNS servers.  Some people simply set up global forwarders for their DNS server.  I don’t recommend doing this because it can cause problems resolving addresse…
    ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now