?
Solved

Fedora 7 Network issues.

Posted on 2007-07-27
28
Medium Priority
?
2,176 Views
Last Modified: 2013-12-06
I'm new to Linux overall and have recently installed Fedora 7 after trying several other distros.  If I follow the startup process I see that eth0 starts up.  If I look at my router/firewall's logs, I can see the linux host being assigned an IP address.  Once everything is started, however, the linux box is unable to resolve anything via DNS, nor is is able to ping even the router by IP address.  I haven't experienced this issue with any other distributions and have tested the ports and cables on known good PCs.   This is a bit perplexing to me.  I don't see any logs on the firewall that suggest the linux box is being denied access in any way.

Any suggestions on logs I might read or troubleshooting steps I might try on the Linux side?

Thanks,

Steve
0
Comment
Question by:corwin_ranger
  • 13
  • 10
  • 5
28 Comments
 
LVL 57

Expert Comment

by:giltjr
ID: 19583232
If you stop the firewall (/etc/init.d/iptables stop) can you ping?
0
 

Author Comment

by:corwin_ranger
ID: 19583302
No.  It seems that eth0 gets disabled after startup and DHCP fails if I try to activate.
0
 
LVL 57

Expert Comment

by:giltjr
ID: 19583324
Have you tried assigning it a static IP address?

Does /var/logs/messages show any errors or why eth0 is failing?
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
LVL 7

Expert Comment

by:ezaton
ID: 19583447
This problem is common with some routers and with Linux IPv6. Disable IPv6 and you might solve the problem. It can be done by following these instructions, as the user root:

edit /etc/modprobe.conf and add the following two line:
blacklist net-pf-10

edit /etc/sysconfig/network and add the following line:
NETWORKING_IPV6=no
(or change such an existing line's value  from yes to no)

Also, disable the ip6tables by running:
chkconfig ip6tables off

Restart your computer, and check again.
0
 

Author Comment

by:corwin_ranger
ID: 19585270
No joy.  I tried ezaton's suggestions with no luck.

When looking atthe messages log, I see an IP address assigned via DHCP.  Eth0 now appears to be active when I look at the status.  I can ping the local host both at the loopback (127.0.0.1) address and at the address assigned via DHCP (192.168.54.132).  I can't ping the router (192.168.54.245), however.   As best I can tell, IPV6 is disabled.
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19585476
Ok - next. What is the output of
ethtool eth0
?
0
 

Author Comment

by:corwin_ranger
ID: 19585558
Interesting.  I get:

Settings for eth0:
No data available.
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19586044
Ok. Take #2:
mii-tool eth0
?
0
 
LVL 57

Expert Comment

by:giltjr
ID: 19586167
When you issue the command:

    ipconfig eth0

is the broadcast address correct?  Sounds almost like the DHCP settings are setting the wrong subnet mask.  Or the router is configured not to allow pings.
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19586369
ipconfig is Windows command. Ifconfig is the right command in Linux.
0
 

Author Comment

by:corwin_ranger
ID: 19586477
OK,

ifconfig shows
inet addr:192.168.54.132 BCast 192.168.54.255 Mask:255.255.255.0

All of which seem correct to me.  Interestingly, it also shows:

inet6 addr: fe80::280:adff:fe739843/64 Scope:Link.

Now, I haven't looked at the IPV6 material at all, so I don't know if that appears to be a valid address or not, but I wouldn't think I'd see anything if IPV6 is disabled.

mii-tool eth0 produced:
eth0: no-autonegotiation, 100baseTx-HD, link ok

Thanks for all the recommendations.  I have only played with Linux and I'm looking to get a good Fedora install for use in when reading O'Reilly's "Running Linux".

Steve
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19586491
Is there a reason your card is not set for auto-negotiation? Unless you have set it yourself, it can be a problem, especially if the other end is set for autoneg...
0
 

Author Comment

by:corwin_ranger
ID: 19586505
Well, having done the networking thing in the past, I've always found that autonegotiation is unreliable at best.  In fact, I have the router specfically set for 100/FULL Duplex, though I don't recall having specifically set that on the Fedora side. Where would I see that config, and what would the line look like?

I've tried using the GUI utilities so far in linux distros, but they hide quite a bit, and given my lack of overall knowledge at this point, I don't know how reliable they are.
0
 
LVL 57

Expert Comment

by:giltjr
ID: 19586600
You can try adding:

     ETHTOOL_OPTS="speed 100 duplex full autoneg off"

to the end of the file /etc/sysconfig/network-scripts/ifcfg-eth0

Sorry about the ipconfig vs ifconfig mix up, I was talking to somebody about a Windows networking problem and asking them to tell me the output from ipconfig.
0
 

Author Comment

by:corwin_ranger
ID: 19587809
No problem on  the mixup, it happens.

OK, so I added the line to ifcfg-eth0.  I didn't expect it to make a difference, and it hasn't

Any other suggestions out there on what to try next?
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19588084
Please post your /etc/modprobe.conf file here.
Thanks.
0
 

Author Comment

by:corwin_ranger
ID: 19588116
Here you go.  This sure would have been easier if I had netowrk access, then I could have cut & paste...LOL:

alias eth0 tulip
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-cs46xx
options snd-card-0 index=0
options snd-cs46xx index=0
blacklist net-pf-10
0
 

Author Comment

by:corwin_ranger
ID: 19607622
Any other suggestions?  Anyone?  Bueller....Bueller?
0
 
LVL 57

Expert Comment

by:giltjr
ID: 19607817
Did you try with a hard coded IP address?

Are there any messages relating to eth0 in /var/log/messages?  You state you have disabled IPV6, did you:

edit /etc/sysconfig/network and add the following line:
NETWORKING_IPV6=no

per ezaton's instructions?  You may also run system-config-network and verify that you have unchecked "Enable IPv6 configuration for this interface".

You may also need to add:

alias net-pf-10 off

to modprobe.conf.  I have never seen the blacklist method of disabling IPv6 until now, not to say that it does not work.  I have see both the blacklist and the alias "off" method documented as working, but the "off" method is documented more often.  However, I don't believe that IPv6 being there is causing this problem.

If using a static IP address does not work, then something in the path is bad: NIC, cable, or switch port.  As you have tested the cable and the switch port with other PC's, that leaves the NIC.

Have you tried with iptables turned off?  "/etc/init.d/iptables stop"

0
 

Author Comment

by:corwin_ranger
ID: 19608093
OK,

I've tried a hard coded IP addres, no luck there.  I've also very recently used this PC with Ubuntu and have had no difficulty with the network card, so I'm not inclined to beleiev that it is the issue..  When I get home this evening, I'll try the other recommendations.

Thanks.
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19614464
I think I can conclude it to a problem with the module "tulip". I haven't used this module in years, and haven't seen any new computer use it, so it could be an incorrect PCI identification. Could you please post the output of
lspci -vv
here?
It will give enough info to allow detection of the PCI Id of the card, and matching it to a correct driver, if the tulip is not one.
0
 

Author Comment

by:corwin_ranger
ID: 19615817
ezaton,

Thanks.  I will post the output this evening after I get home.
0
 

Author Comment

by:corwin_ranger
ID: 19621723
OK, so here's the output of lspci that relates to the ethernet controller:

BTW - According to Dell it's a CNET PRO200WL Ethernet card

02:09.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC Tulip compatible 10/100 Ethernet (rev 31)
     Subsystem: Unknown device 4554:434e
     Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
     Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
     Latency: 64 (5000ns min, 10000ns max)
     Interrupt: pin A routed to IRQ 19
     Region 0: I/O ports at e800 [size=256]
     Capabilities: [50] Power Management version 2
          Flags: PMEClk- DSI- D1- D2- AuxCurrent=220mA PME(D0+, D1+, D2+, D3h, ot+, D3cold+)
          Status: D0 PME-Enable- DSel=0 DScale=0 PME+

If you need mre info, let me know.

Thanks again,

Steve
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19621784
You can try the following (and you need to follow this up closely):
1. service network stop
2. rmmod tulip
3. ifconfig -a (you should see only the device 'lo')
4. insmod dmfe
(if there are no error messages)
5. ifconfig -a (do you see eth0 as well?)
(if you see eth0)
6. ifup eth0
If it works correctly, change the entry in your /etc/modprobe.conf from:
alias eth0 tulip
to
alias eth0 dmfe

Save, restart and let me know what happens.
0
 
LVL 7

Accepted Solution

by:
ezaton earned 2000 total points
ID: 19621790
Ah, reference:
http://ubuntuforums.org/showthread.php?p=1204275
Similar problem. Solution fits Ubuntu, but based on the same problem. Davicom (dmfe) is not tulip.
0
 

Author Comment

by:corwin_ranger
ID: 19626636
ezaton,

Thanks for the info. I was able to check out that link quickly.  I'm going to try the fix tonight.  I'll update you then.
0
 

Author Comment

by:corwin_ranger
ID: 19629035
ezaton,

Thanks for all your help.  That took care of it.
0
 
LVL 7

Expert Comment

by:ezaton
ID: 19629290
With pleasure :-)
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question