Wake-On-Lan from hibernation in Fedora

I'm trying to setup a fileserver running Fedora 7 that uses Wake-On-Lan to remotely power up from S4 or S3 because these are the options that work according to the BIOS. I'm fairly certain that it's possible to make it work since the ethtool reports the NIC supports the pumbg options. And indeed, when I set the b option (broadcast) and then send a packet over the broadcast address the PC powers up from S4 and S3 even though the lights on the NIC are off.

However this is not ideal and I really need the magic packet option to work. Since the broadcast option is working it's safe to assume that there's no problem with the power supply or the WOL connection. (It's an onboard NIC anyways).

In short I need a way to enable the 'wake on lan with a magic packet option' Some options that I've tried already:

-adding a hook script to cd /etc/pm/sleep.d
-adding options to the halt script (which doesn't work because I'm using S3/S4?)
-using ethtool -s eth0 wol g right before hibernate/suspend
-using ethtool -s eth0 wol bg right before hibernate/suspend (when the PC wakes up after this sometimes only the b option is still enabled or the wol functions are completely disabled.)

I hope we can find a solution to this rather annoying problem.
KVoetAsked:
Who is Participating?
 
jakosysadminCommented:
Interesting, 8139too should be one of the most used kernel modules out there which in turn should make your embedded NIC one of the most common ones.

do you have a 8139too specific line in your /etc/modules.conf ?
try adding following:

      post-install 8139too ethtool -s eth0 wol umbg
0
 
jakosysadminCommented:
What kind of a NIC chip there is on your motherboard? Probably the easiest way (and cheapest when taking into account the cost of time) for you to make it work is to buy a "tried and tested" PCI NIC with WOL that has proper Linux drivers. That however implies that in spite of built in WOL, there's a WOL socket on the motherboard (seen this on several occasions and if you're lucky, this might be the case with yours).
0
 
KVoetAuthor Commented:
I've looked it up and it's a Realtek 8139 chip if that's any help. I'm just about ready to give up and try installing Windows XP again to test the WOL options there.

And I'm afraid there aren't any PCI slots left in the PC so that will be a problem for your suggested solution.
0
 
KVoetAuthor Commented:
Actually the /etc/modules.conf didn't exist on my Fedora 7 installation.
I've created it and added the command as you suggested.

There's another oddity I've just discovered. When manually setting the wol options
using ethtool -s eth0 wol umbg and then hibernating using the pm-hibernate command
(ethtool reports: "wake on: umbg")
the PC wakes up (probably due to the broadcast) but when using the
ethtool eth0 command reports "wake on: umb"

So as you can see, the g option appears to have disappeared.
0
 
KVoetAuthor Commented:
After reinstalling Windows XP on a small partition it appears the Magic Packet options works when hibernating from Windows XP. Is there any way how I can now make this work from Linux as I'm 100% sure it works under another operating system.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.