How to connect Tomcat with Microsoft IIS 6.0?

I know this question has been asked numerous times in the forum, but I am still having trouble connecting Tomcat version 5.5 with Microsoft Internet Information Services.
I am using the AJP13 connector and I have configured the isapi_redirect using the isapi_redirect.properties file and also via the registry, both I always get a 404 error when I connect via IIS. If I connect using http://localhost:8080/context/...jsp, it works.. Any help will be appreciated in this matter.

Thanks.
principiamgmtAsked:
Who is Participating?
 
Computer101Connect With a Mentor Commented:
PAQed with points refunded (125)

Computer101
EE Admin
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
cj_1969Commented:
You can also check out this page ... this appears to be a common problem ...
http://www.mail-archive.com/users@tomcat.apache.org/msg31723.html
0
 
principiamgmtAuthor Commented:
Thanks for the links. I have looked at them but still are not useful. I looked at the IIS log and it is not even reporting the /tomcat/isapi_redirect.dll entry. It just says 404. So, I am assuming that it cannot even load up the isapi_redirect. But in my IIS website, the ISAPI filter has been configured and loaded.
What else should I be looking at?
0
 
principiamgmtAuthor Commented:
ok, I found out the problem myself. In IIS 6.0, you need to add the isapi_redirect.dll as a web service extension before it can work, duh...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.