Server to server data transfer is very slow

Posted on 2007-07-30
Last Modified: 2010-04-18
Hell all
Hava a performance issue on two servers:
Both are identical setups:

Server 2003 SP1, Dual Processors, 4gB ram.  Dual NIC cards but one is dissabled and the enabled is set to 100 Full.

Problem is file transfers between the two are very slow but file transfers to other machines are fine.  This is a remote office with 5 pc's and 4 printers.  It was first identified this was happening when the backups began to fail.  Like I said earlier the setups are identical.  

Was liiking at both and noticed the paging file on one is at 1.5 GB where as the other is at 441MB.

Any suggestions on what to look for?

Question by:wgilbert
    LVL 9

    Expert Comment

    First off, the page file should be set to 1.5x the amount of Physical Ram, just as a general rule of thumb.
    That could be the root of your issues, but i doubt it.

    Are your servers acting as Application or Data storage servers that take on a lot network traffic?  this could also be causing the issues.



    Author Comment

    they are both file and print servers.  One is primary other is backup.  Data storage only.
    LVL 5

    Expert Comment

    I had a client with this same problem just a few weeks ago.  the problem was initially caused by incorrect attempts at teaming the nics.  this introduced some kind of corruption into the bindings and/or client services on the nics.  go to the properties of the nics in question and see if they are all listing the same stuff (like Client for MS networks, TCP/IP, etc.)  We fixed this problem when we found we need to add a service/client that wasn't listed there, added it and reinitialzed the nic.  

    Author Comment

    the NIC's were teamed till last week on both servers but canot confirm if the problm started or changed at that point.  

    I checked the NIC settings are they are identical to servers in other locations.
    LVL 5

    Accepted Solution

    consider teaming them again and see if it resolves the problem.  when you team, leave the nics as dhcp and apply static to the virutual team.  if you have an ip on each nic now and they are not teamed, disable the nic that is not in use.

    Author Comment

    The Fix was to set the NICS to auto config (speed).  Thanks for the suggestions.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Transparency shows that a company is the kind of business that it wants people to think it is.
    Join Greg Farro and Ethan Banks from Packet Pushers ( and Greg Ross from Paessler ( for a discussion about smart network …
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now