• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4306
  • Last Modified:

Exchange 2007 Send As config :

Dear experts,

Im trying to implement send as option for same users in the company , but not succeed it.

I always get an error from exchange :

Delivery has failed to these recipients or distribution lists:

UserName

You are not allowed to send this message because you are trying to send on behalf of another sender without permission to do so. Please verify that you are sending on behalf of the correct sender, or ask your system administrator to help you get the required permission.


I all ready did this:

Add-ADPermission -Identity "Ellen Adams" -User TedBrem -AccessRights extendedright -ExtendedRights "send as"

But still having same problem.

So , can you please advice , and by the way I was trying to find out how to see logs in the server in order to check the SMTP errors but dont know how to check logs .im know the event viewer , but no details about this.

Thanks in advance
0
diegomirner
Asked:
diegomirner
1 Solution
 
ATIGCommented:
so user TemBrem is tryinig to send As ellen Adams?

Are you doing this from outlook or OWA?

Add-ADPermission -Identity "Ellen Adams" -User TedBrem  -ExtendedRights "send as"

if not add

add-mailboxpermission -Identity "Ellen Adams" -User TedBrem -accessrights sendas

http://www.exchangeninjas.com/allaboutadpermissiontasks

sp1 will bring you the gui for this back :P
0
 
diegomirnerAuthor Commented:
i try it , but still same problem , I just test the option send in behalf on the console and same problem , thats way I was trying to check logs in order to check for errors .

Any idea ???
0
 
ATIGCommented:
do a get on your permissions get-adpermission ellen adams | fl
and see if you have send as
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
diegomirnerAuthor Commented:
Are you sure about that command ? its confusing
0
 
ATIGCommented:
sorry do get-mailboxpermission "ellen adams" | fl

This will show you all the permission on that object.....
0
 
Ozone214Commented:
Hi diegomirner - it looks like you're setting the permission on the Active Directory account but not the mailbox.  try this:

Add-ADPermission "ellen adams" -ExtendedRights Send-As -user TedBrem
Add-MailboxPermission "ellen adams" -AccessRights SendAs -user TedBrem
0
 
ATIGCommented:
Ozone:

The Send-AS right related to add-mailboxpermission does not do anything and is left over from legacy permissions.

The only way to apply Send-AS with with add-ADpermission

below are 2 blogs that I wrote related to both these permission and what they all you to do.

http://exchange-genie.blogspot.com/2007/07/add-mailbox-permission-vs-add.html
http://exchange-genie.blogspot.com/2007/08/add-adpermission.html
0
 
diegomirnerAuthor Commented:
I see sendas permission in the ser , bu im not abalible to send email , so same thing its going wrong here.
I have 2 AD server , i can see that the wirtes are in booths servers , but still not working.
Do you know how to flush the cache in AD server ? can help that ????
0
 
diegomirnerAuthor Commented:
For same users works , for other not , im using addadpermission , any idea how to solve this ??????
0
 
ATIGCommented:
manipulating the permissions could take up to 2 hours to take effect unless you restart some sercies
0
 
diegomirnerAuthor Commented:
could you please gibe me details about witch services i need to restard , i can find the porblem
0
 
ATIGCommented:
1 are you delegating to an account that may have a deny on it?

get-adpermission | fl

restarting the IS should do it but worst case just restart all the EX services

if its still not working most likely the account is a memeber of a group with deny on it
0
 
diegomirnerAuthor Commented:
so , a bit late but i have manage to find the real problem , i have inconsistens on my AD database , i will run same mantinance database in ofline mode in order to solve the problem, if you know doc that can help me , please add it on the post
thanks again
0
 
MeridianBioCommented:
Another Excellent solution. Resolved my issue.

Thanks
0
 
happyexchangeCommented:
Go into your delivery options and click on add.

Its the grant this permission to.

I had that problem and thats ho i fixed mine
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Tackle projects and never again get stuck behind a technical roadblock.
Join Now