?
Solved

Outlook RPC Problems

Posted on 2007-07-30
5
Medium Priority
?
594 Views
Last Modified: 2011-09-20
I am trying to setup Exchange RPC and having huge problems.  I have two server certificates, one for mail and one for www.mcrowd.com and I have the mail.mcrowd.com one setup on IIS exchange server.  I have a certificate for www and need to use SSL on port 443 on this one as well, they seem to block each other when I try to run the sites.

I have basic authentication enabled. I am trying to connect through Outlook, I have the following settings:

Use Cached Exchange Mode
MRG001SRVEXCH.mcrowd.com is he Exchange Server Name
General -> Automatically Detect Connection State
 Security -> Encrypt data between Microsoft Outlook and Exchange Server
Connection -> Connect using my LAN
Connection -> Connect to my Exchange mailbox using HTTP
Connection -> Exchange Proxy Settings -> https://mail.mcrowd.com
Connection -> Exchange Proxy Settings -> Connect using ssl only
Connection -> Exchange Proxy Settings -> Mutually Authenticate
Connection -> Exchange Proxy Settings -> msstd:mail.mcrowd.com
Connection -> Exchange Proxy Settings -> On fast networks
Connection -> Exchange Proxy Settings -> On slow networks
Connection -> Exchange Proxy Settings -> Basic Authentication

When I am using it on the corporate lan it connects fine, but I use outlook /rpcdiag and it shows TCP/IP under Conn not HTTPS.  When I goto the internet I just get Connecting continually.  I have the firewall setup for 443 and 80, 6001, and 6004.  Any help on this would be greatly appreciated.

Thanks,

Jason
0
Comment
Question by:jasonldavis
  • 2
3 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 19596966
If you are getting TCP/IP on the LAN then the feature is NOT working correctly. That is how Outlook connects by default.

You cannot mix the SSL certificates or their addresses. Therefore you need to first ensure that the correct certificate is on the default web site.
If you go to https://mail.mcrowd.com/rpc internally, do you get a certificate prompt? If you do then the feature will not work.
You need to resolve that first.

Next, change your firewall, you do not need port 80, 6001 and 6004 open for this feature to work, you only need 443.

The most common cause of failure is registry settings. I suggest that you look at my section on RPC over HTTPS on my web site: http://www.amset.info/exchange/rpc-http.asp

Simon.
0
 

Author Comment

by:jasonldavis
ID: 19603421
The correct certificate is on the default website, I check https://mail.mcrowd.com/rpc and it worked correctly.  I have added the registry settings.  I run a Domain Controller on a seperate computer than the Exchange server.  Our Domain controller died about a year ago and had to rebuild it, I also had alot of problems upgrading to service pack 1, its a dell poweredge 2850.  I applied the registry settings to the domain controller (the domain controller specific ones) the last thing I can think is it might be a DNS error in the RpcProxy Reg setting I have MRG001SRVEXCH.mcrowd.com which is the fully qualified internal domain name, I have mail.mcrowd.com (these both have 6001-6002, 6004).   Is there anyway to force RPC on the LAN so that it doesn't default back to Normal Exchange?  Do I need to apply any new service packs to exchange? I believe we are on SP1 for 2003.  The laptop I was testing on was Vista so I tried some of the solutions I found for setting the policy RPC.  Anyways I am shooting in the dark right now, still want to get this up and going.  I tested it on an XP laptop and had the same prob.

Thanks for the help,

Jason

0
 
LVL 104

Accepted Solution

by:
Sembee earned 2000 total points
ID: 19608613
You shouldn't be asking about service packs for Exchange. They are not an optional installation. SP2 for Exchange 2003 has been available for almost two years and should be installed on Exchange 2003 servers.
However the installation of SP2 will not affect the operation of RPC over HTTPS.

If you enable both options for fast and slow connections to use https then the LAN connection will attempt to use RPC over HTTPS. You do need to ensure that the name on the certificate resolves internally to the correct internal IP address of the Exchange server.

Simon.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
Steps to fix “Unable to mount database. (hr=0x80004005, ec=1108)”.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses
Course of the Month16 days, 15 hours left to enroll

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question