Exchange 2007 - Custom view of Open Additional Mailboxes

We have Exchange 2007 and there are several mailboxes that are generic (ie. sales@domain.com, orders@domain.com) and we have granted several people full access to these mailboxes in order that they may open them as "additional mailboxes".  

Everything works as planned with the exception of one little thing.  When the users expand the mailbox in their outlook, they get every folder, everthing including Calander, Tasks, Notes, Inbox, etc.  I just want the users to be able to expand the mailbox and just see the Inbox.  Not for any security reason, but just because it's easier to manage that way.  Can this be done?
LVL 2
tphelps19IT ManagerAsked:
Who is Participating?
 
mass2612Connect With a Mentor Commented:
The only other way I can think of if you want just the inbox showing in the folder view is to manually assign the permissions from within outlook 2003. Open the generic mailbox and right click on the each of the folders i.e. Inbox > Properties > Permissions and assign the permissions through there. I've not tried this in a 2007 environment but I would be fairly sure that the client side permissions would still be the same. If you assign the permissions at the top level i.e. Mailbox - Generic mailbox name then they should be able to view the mailbox as an additional mailbox in their profile just like you have it setup now but you will set the permissions on the specific folders so that they can only view the ones that you need them to view.

http://msexchangeteam.com/archive/2006/05/01/426936.aspx - this talks about the other users folder thing but I post it here so you can view the outlook permissions area./
0
 
mass2612Commented:
Hi,

Not sure in Outlook 2007 if that's what you are using but in 2003 in this situation I would provide the users with delegate access to the generic mailboxes so that they can only open the Inbox and then have them open the mailbox via Open > Other Users Folder > Inbox in Outlook. They can also retain the send as or send on behalf permissions also to allow this option.

To do this you would remove the full mailbox access via AD and open the generic mailbox and add the user groups as delegates via OUtlook Tools > Options > Delegates > Add > Group/user name > Inbox > Ok.
0
 
tphelps19IT ManagerAuthor Commented:
We have Outlook 2003 but Exchange 2007.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
mass2612Commented:
I would simply be using the delegate option as I said above. Its simple well tested and should do what you need. Give it a go anyway.
0
 
tphelps19IT ManagerAuthor Commented:
This is'nt going to work.  For one, Exchange 2007 is not integrated into AD the awy 2003 was and second, with your option that means the user cannot see when there are new messages in the inbox, they have to manually go Open > Open other users folder each time.  

Is there any other solutions?
0
 
tphelps19IT ManagerAuthor Commented:
This doesn't work.  I tried setting the permissions but that only works if  you use the File > Open > Open other users inbox option.  I want to be able to expand the mailbox and see just the inbox & sent items.  Any other ideas?  I know this can be done... there's got to be a way...
0
 
mass2612Commented:
No sorry I am very suprised that setting the permissions at the top level of the mailbox and then the inbox and sent items does not work but I can't test it myself with Exchange 2007 at the moment so if you are sure you have set the permissions at the top level Mailbox - Mailbox name and then the inbox etc I'm out of ideas for the moment. If you don't do the permissions at this level then yes you can only use the open other users folder option but assigning at the top level allows the mailbox to be expanded in the list.

Good luck. Please anyone else out their done this in Exchange 2007/Outlook 2003 environment??
0
 
tphelps19IT ManagerAuthor Commented:
Wait... I'm an idiot.  I didn't do it on the top level, I was only doing the inbox.  :(
Looks like that is going to be our option.  :)
I did have the permission in Exchange set to ReadPermission in the cmdlet, so not sure if that had anything to do with it.  Thanks for your help.
0
 
mass2612Commented:
Ok great. So is it dinfately working as I tried to describe? Let us know if you get the chance. Thanks again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.