• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 781
  • Last Modified:

Exchange can't receive external emails

We have exchange 6.5 and are having problem receiving external emails.  We can send external and internal emails, receive internal emails, but can't receive external emails.  I ran a check on the domain at checkdns.net.  It passed everything except we had 1 error.

    Error connecting to mail server inbound.mail.ourdomain.com [xxx.xxx.xxx.xxx] port 25 : timed out waiting for connection

  Any ideas?
0
cntech
Asked:
cntech
3 Solutions
 
SembeeCommented:
That means what it says - the testing server was unable to connect to your server.
You need to see where the block is taking place, so internally look to see whether the SMTP service is running, whether you can telnet to port 25. Then look at your firewall to ensure that SMTP port 25 is open and pointing at the correct internal IP address. Finally check with your ISP to ensure that the port hasn't been blocked over the weekend.

Simon.
0
 
cvvoodCommented:
Simon,  Hitting the Nail on the Head again!!

If you want to know what your mail address is go to your mail server and from IE goto www.ipchicken.com.......

Then you can start on the router/firewall/NAT that seems like the problem....

Simon,   Get some rest...   :)


cvv
0
 
amajidkhCommented:
First of all is this a recent problem? Was it working previously?

You are able to send out mail as you may be using DNS for name resolution or a smarthost.

Test telnet internally first you may do either on the server or via workstation:
See: http://support.microsoft.com/kb/153119 basic testing area.

If you are able to connect then move to testing the gateway. I would

1. First logonto the server run a scan port
http://www.grc.com/x/ne.dll?rh1dkyd2  i have used in the past if your firewall/router is not operating in s stealth mode you should be able to see what ports are actually open inbound.
2. Depending on the outcome logonto your firewall/router and check either the port redirection or the firewall setting as Simon has suggested.

mk

0
 
cntechNetwork ManagerAuthor Commented:
This is a recent problem, as it previously worked.
0
 
cntechNetwork ManagerAuthor Commented:
After looing into this, the mx record was messed up, after we changed it everything worked.

   Thanks for you ideas.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now